Home/Support/Support Forum/error discovering neighbors of
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

error discovering neighbors of

–1 vote
I spent almost a month because of this problem.
I just wanted to draw a ZigBee map with recently purchased xStick USB in my house and I'm using Tuya Zigbee hub and some terminal devices such as lamp, light and some switches.
I have an xStick and it is connected my desktop through USB serial port COM9.
At first it was set as Baudrate was 9600, Data Bits 7, Parity none, Stop bits 1, Flow control none.
When I ran the program I can detect xStick in XCTU program and set port parameters as above but failed in drawing of ZigBee map because "Error discovering neighbors of 0013A....". I could see there is no C or R, etc on big icon in the left windows.
After many trial I could see ZigBee icon changed to "R" as router and could draw ZigBee map once in a short time and then lost again.
I formatted my computer and installed XCTU. The xStick is now changed to COM4 and I can detect xStick only in the setting of Baudrate 115200, Data Bits 8, Parity none, Stop bits 1, Flow control none. But I can't proceed further because I have error popup as "Error discovering neighbors of 0013A...." again.
How can I make correct setting and draw ZigBee map again?
asked Apr 5 in USB by grearjoo New to the Community (1 point)

Please log in or register to answer this question.

3 Answers

+1 vote
Try issuing a Local Network Reset on your XStick. You will want to use the API frames Generator to help you do that. You will also want to make sure that the radio is in API mode.
answered Apr 5 by mvut Veteran of the Digi Community (14,297 points)
0 votes
Thank you for your information.
I tired to find the optimal setting for my radio module first. and found out that COM4 port with Baudrate: 115200, Data Bits: 8, Parity: none, Stop bits: 1, and flow control: none.
Now I can always get connected with above information. But as you advised me, I tried to Local Network Reset on XStick, I have still problem. Can you tell me how to use API frames Generator, and how can I check radio is in API mode?
Thank you in advance.
Hans
answered Apr 6 by grearjoo New to the Community (1 point)
0 votes
had the same problem. The advice above is effective
answered Apr 23 by Roopert8 New to the Community (1 point)
...