Home/Support/Support Forum/Error loading firmware file to RAM - ccimx6ul
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Error loading firmware file to RAM - ccimx6ul

0 votes
After the update to Release 3.0-r3 and the u-boot-2020.04 I am not able to update the *boot *recovery and *rootfs images.

Everytime I try for example:
update linux mmc 0 fat diaip-image-base-diaip-01-20210331102923.boot.ubifs

I get the following error:
Error loading firmware file to RAM


If I update it using a TFTP-Server it works without any problems.

If I downgrade to the old U-boot (2017), I can install the images using an SD-Card.

Edit:
I read through the last Questions and
https://www.digi.com/support/forum/78515/connectcore-express-firmware-upgrade-installation-failed

seems to be kind of the same problem
asked Mar 31 in Linux by dbau New to the Community (15 points)
edited Mar 31 by dbau

Please log in or register to answer this question.

1 Answer

+1 vote
 
Best answer
This is a known issue with u-boot for cc6ul starter board on dey-3.0r3. We are in the process of releasing de-3.0r4 where it is fixed. It might have already pushed to git , so if you update your Yocto

~$ repo init -u https://github.com/digi-embedded/dey-manifest.git -b zeus
~$ repo sync -j8 --no-repo-verify

you should get the latest version of u-boot with fix.
answered Apr 2 by LeonidM Veteran of the Digi Community (4,149 points)
selected Apr 13 by dbau
Unfortunately, I still have the same problem.
I tried it with the updated repo and the r4 Images of the starterboard:

=> update uboot tftp u-boot-ccimx6ulstarter.imx                                 
Do you really want to program the boot loader? <y/N> y                          
Using FEC0 device                                                               
TFTP from server 192.168.73.191; our IP address is 192.168.73.46                
Filename 'u-boot-ccimx6ulstarter.imx'.                                          
Load address: 0x80800000                                                        
Loading: #################################################                      
         4.1 MiB/s                                                              
done                                                                            
Bytes transferred = 715776 (aec00 hex)                                          
Writing bootstream...OK                                                         
=>                                                                              
                                                                                
U-Boot dub-2020.04-r3.1+g749d90196c (Mar 09 2021 - 01:42:17 +0000)              
                                                                                
CPU:   i.MX6UL rev1.2 528 MHz (running at 396 MHz)                              
CPU:   Industrial temperature grade (-40C to 105C) at 44C                       
Reset cause: POR                                                                
I2C:   ready                                                                    
DRAM:  256 MiB                                                                  
MCA:   HW_VER=1  FW_VER=1.01                                                    
PMIC:  PFUZE3000 DEV_ID=0x30 REV_ID=0x11                                        
NAND:  256 MiB                                                                  
MMC:   FSL_SDHC: 0                                                              
In:    serial                                                                   
Out:   serial                                                                   
Err:   serial                                                                   
Model: Digi International ConnectCore 6UL Starter Board.                        
ConnectCore 6UL SOM variant 0x03: Industrial Ultralite 528MHz, 256MB NAND, 256MC
  Board version undefined, ID undefined                                         
Boot device:  NAND                                                              
Net:   FEC0 [PRIME]                                                             
Fastboot: Normal                                                                
Normal Boot                                                                     
Hit any key to stop autoboot:  0                                                
=>                                                                              
=>                                                                              
=>                                                                              
=> update linux mmc 0 fat core-image-base-ccimx6ulstarter.boot.ubifs            
Error loading firmware file to RAM
Please remove "fat" from the command line. Newer u-boot does not use partition type, I believe. Does it work now?
Ah ok.
But still the same problem:
=> update linux mmc 0 core-image-base-ccimx6ulstarter.boot.ubifs
Error loading firmware file to RAM
can you do "ls mmc 0" and provide output?
=> ls mmc 0
   715776   u-boot-diaip-01-2020.04-r0.imx
            System Volume Information/
   715776   u-boot-ccimx6ulstarter.imx
 12697600   core-image-base-ccimx6ulstarter.recovery.ubifs
 78090240   core-image-base-ccimx6ulstarter.ubifs
  8634368   core-image-base-ccimx6ulstarter.boot.ubifs

5 file(s), 1 dir(s)
I tried it with a new device and a new SD-Card.
Now it works! Thank you
...