Home/Support/Support Forum/Bluetooth mobile app can't connect to XBC

Bluetooth mobile app can't connect to XBC

+2 votes
I have an XBC-LTE-M/NB-IoT Global (XBXC3) with firmware 11410 on it, and it refuses to connect to the mobile app. Authentication seems successful, but:

Connect error
Could not connect to the XBee device >
The selected XBee device is not supported.
Please update the radio firmware definitions
(Options > Check for firmware updates).


I did what it suggested and it says "No radio firmware updates available." It seems like this should work, any idea why it doesn't?

I tried upgrading the firmware to 11417 and the XBee firmware upgrade worked, but didn't solve the problem. (I don't have a cable to upgrade the LTE module, so I had to revert back to 11410 to get it on the cellular network again).

I'm attempting this from a Pixel 3XL running android 11. It detects the device just fine, and a BLE scan from the phone shows the right GATT service / characteristics (UUIDs match) so I'm pretty stumped why this wouldn't work.

Note: I do note, too, though, that XCTU firmware updating fails, and the B.S. about "turn off your firewall / virus" isn't the problem. I know that's an easy answer to throw out, but it doesn't work even if I completely disable both of those, and I tried it on multiple computers. I'm not sure if these things are related or not.
asked Dec 28, 2020 in XBee Cellular by wz2b New to the Community (48 points)

Please log in or register to answer this question.

1 Answer

0 votes
wz2b, Looks like you have a two fold issue. First, you will want to update both the Digi and Modem code to the latest supported. You may need to obtain an XBIB-CU-TH board and associated cables to do that. Or you can perform the updates using over the wire/FOTA options. Note that these take longer and can use large amounts of data.

Once you are updated, you should be able to access the BLE function from your phone. I would suggest using the Digi XCTU for Andrio to verify that with after the update is done.
answered Dec 28, 2020 by mvut Veteran of the Digi Community (14,578 points)
Also, the error "The selected XBee device is not supported. Please update the radio firmware definitions" occurred because the mobile app looks in a different location on digi.com for XBee firmwares than XCTU, and the firmware definition for 11417 had not been posted yet. I have confirmed that it is now in place, so that error should not occur anymore.
...