Home/Support/Support Forum/ConnectCore 6UL SBC Pro: hostapd not working in 5GHz since Digi Embedded Yocto 3.0
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

ConnectCore 6UL SBC Pro: hostapd not working in 5GHz since Digi Embedded Yocto 3.0

0 votes

after switching to Digi embedded yocto 3.0 I was not able to get the soft AP with hostapd working in 5GHz.
In 2.4GHz range it is working well.

The /etc/network/interfaces contains:
auto wlan1
iface wlan1 inet static
post-up /etc/init.d/hostapd start
pre-down /etc/init.d/hostapd stop

The /etc/hostapd_wlan1.conf is:

# IEEE 802.11ac 5GHz


There is an error message in /var/volatile/log/messages
Oct 1 12:56:18 btc daemon.warn hostapd: wlan1: IEEE 802.11 Configured channel (36) not found from the channel list of current mode (2) IEEE 802.11a
Oct 1 12:56:18 btc daemon.warn hostapd: wlan1: IEEE 802.11 Hardware does not support configured channel

Thanks in advance,
asked Oct 5, 2020 in Linux by uwel New to the Community (4 points)

Please log in or register to answer this question.

1 Answer

0 votes
There was an issue with the regulatory domain in the previous release only in the cc6ul platform, this was causing the hostapd not bringing-up in 5ghz bands. It will be solved in the following release dey-3.0-r2 coming up within a month.

If you want to try it now, you should enable in the ccimx6ul_defconfig in the linux kernel the following configurations:

answered Oct 8, 2020 by LeonidM Veteran of the Digi Community (4,366 points)
Thanks for the advise.
There are two files ccimx6ul_defconfig but none of them contains CONFIG_FW_LOADER_USER_HELPER
uwe@ubuntu:~$ find / -name ccimx6ul_defconfig -exec ls -l {} \; 2>&-
-rw-r--r-- 1 uwe uwe 8423 Sep 25 17:59 /home/uwe/pe/tmp/work-shared/ccimx6ulsbc/kernel-source/arch/arm/configs/ccimx6ul_defconfig
-rw-r--r-- 1 uwe uwe 8423 Sep 25 20:14 /home/uwe/pe/tmp/work/cortexa7t2hf-neon-mx6ul-dey-linux-gnueabi/linux-imx-headers/5.4-r0/git/arch/arm/configs/ccimx6ul_defconfig

To which file the two lines should be added?
Most likely the first one, but I wouldn't try to change config files manually. Please follow the procedure here and change via menuconfig in a proper yocto way:
Thanks for the advice. I did:
uwe@ubuntu:~/pe$ source dey-setup-environment
uwe@ubuntu:~/pe$ bitbake -c menuconfig virtual/kernel
Then I search for CONFIG_FW_LOADER_USER_HELPER and .. FALLBACK and found it in
Defined at drivers/base/firmware_loader/Kconfig:71
Defined at drivers/base/firmware_loader/Kconfig:143

and changed in Device Drivers/Generic Driver Options/Firmware loader
*- Firmware loading facility
(imx/sdma/sdma-imx6q.bin) Build named firmware blobs into the kernel binary
(firmware) Firmware blobs root directory
[*]   Enable the firmware sysfs fallback mechanism
[*]     Force the firmware sysfs fallback mechanism when possible
[*]   Enable compressed firmware support

But the ccimx6ul_defconfig have not been changed:
uwe@ubuntu:~$ find / -name ccimx6ul_defconfig -exec ls -l {} \; 2>&
--rw-r--r-- 1 uwe uwe 8423 Sep 25 17:59 /home/uwe/pe/tmp/work-shared/ccimx6ulsbc/kernel-source/arch/arm/configs/ccimx6ul_defconfig
-rw-r--r-- 1 uwe uwe 8423 Sep 25 20:14 /home/uwe/pe/tmp/work/cortexa7t2hf-neon-mx6ul-dey-linux-gnueabi/linux-imx-headers/5.4-r0/git/arch/arm/configs/ccimx6ul_defconfig

Then I did
uwe@ubuntu:~/pe$ bitbake -C compile virtual/kernel
which created a new zImage and Device tree
Then I did:
uwe@ubuntu:~/pe$ bitbake -c cleanall core-image-base
uwe@ubuntu:~/pe$ bitbake core-image-base
and flashed the boot and rootfs

but unfortunately with no succes:
root@ccimx6ulsbc:~# iw list

                        * 5180 MHz [36] (20.0 dBm) (no IR)
                        * 5200 MHz [40] (20.0 dBm) (no IR)

So I think it is best to wait for the dey-3.0-r2 and hope it works with that release.

and find it in
yes, I agree. dey-3.0-r2 is really around the corner.
With new Release 3.0-r2 it is working well again!
Pls see https://https://github.com/digi-embedded/meta-digi
good news! Please click Checkmark next to select the answer if you are satisfied with the answer.