Home/Support/Support Forum/How to disable xbee pro s2c boost mode

How to disable xbee pro s2c boost mode

0 votes
I am using xbee pro s2c in boost mode where Tx_power is 18dB, but i want to set it on 5 or 8dB so for that i need to disable boost mode.

I have tried sending AT command PM (Power Mode) but i am getting status error time i tried.

1) How to disable that mode?
2) As per datasheet at 18dB xbee should consume 120mA current but mine is taking only 30 to 45mA max why?
asked Sep 10, 2020 in XBee Programmable Development by bhavitrajput New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
Use the following commands>

+++
ok
ATPL0 <CR>
ok
ATPPM0<CR>
ok
ATWR<CR>
ok



The radio is transmitting at 250Kbps. Unless you are using the proper hardware, you are not going to see the peak current draw when it is transmitting.
answered Sep 10, 2020 by mvut Veteran of the Digi Community (14,807 points)
I have tried AT command as you said but I am getting an ERROR in response whenever I hit the ATPM0 or ATPPM0 command.
What firmware version are you working with?
I have tried on 4060 and 4061 fw version.
What do you get if you simply issue the ATPM ?
I got 1 in the response of ATPM
Ok so now do the same thing. This time with a zero. So it looks like:

ATPM0
I have tried that ATPM0 or ATPM1 in both the case i am getting ERROR in response.
What does ATVR report?
ATVR Response is 4061.
I would suggest contacting Digi support via email at tech.support@digi.com.   Make sure you include the full part number, firmware version and serial number for the device that is having issues.
...