Home/Support/Support Forum/Build core-image-base fails because of TCF Agent
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Build core-image-base fails because of TCF Agent

0 votes
Hi,

Target: i.MX6UL Starter Kit
Host OS: Ubuntu-16.04 LTS (x86_64)
Build Environment: Digi Embedded Yocto
Issue: Build images failed due to invalid TCF agent link

I installed the Digi Embedded Yocto following this guide:
https://www.digi.com/resources/documentation/digidocs/90001548/#task/yocto/t_install_dey.htm%3FTocPath%3DDigi%2520Embedded%2520Yocto%7CSystem%2520development%7C_____1

Then I'm trying to build project with core-image-base conf:
https://www.digi.com/resources/documentation/digidocs/90001548/#task/yocto/t_create_build_projects_yocto.htm%3FTocPath%3DDigi%2520Embedded%2520Yocto%7CSystem%2520development%7C_____2

But I'm facing the following issue about TCF agent that can't be fetched from the following and even on mirrors:
git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent;branch=1.5_oxygen_bugfix

Access to the link: "git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent" on a navigator confirms that (404 file not found).
Here is the right link:
git.eclipse.org/c/tcf/org.eclipse.tcf.agent.git

Below is the output of the compilation error:
WARNING: tcf-agent-1.5+gitAUTOINC+5ec928ddf6-r0 do_fetch: Failed to fetch URL git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent;branch=1.5_oxygen_bugfix, attempting MIRRORS if available
ERROR: tcf-agent-1.5+gitAUTOINC+5ec928ddf6-r0 do_fetch: Fetcher failure: Fetch command export DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-PrOtj6aeas"; export SSH_AUTH_SOCK="/run/user/1000/keyring/ssh"; export PATH="/home/younes/workspace/ccimx6ulstarter/tmp/sysroots-uninative/x86_64-linux/usr/bin:/usr/local/dey-2.2/sources/poky/scripts:/home/younes/workspace/ccimx6ulstarter/tmp/sysroots/x86_64-linux/usr/bin/arm-dey-linux-gnueabi:/home/younes/workspace/ccimx6ulstarter/tmp/sysroots/ccimx6ulstarter/usr/bin/crossscripts:/home/younes/workspace/ccimx6ulstarter/tmp/sysroots/x86_64-linux/usr/sbin:/home/younes/workspace/ccimx6ulstarter/tmp/sysroots/x86_64-linux/usr/bin:/home/younes/workspace/ccimx6ulstarter/tmp/sysroots/x86_64-linux/sbin:/home/younes/workspace/ccimx6ulstarter/tmp/sysroots/x86_64-linux/bin:/usr/local/dey-2.2/sources/meta-digi/scripts:/usr/local/dey-2.2/sources/poky/scripts:/usr/local/dey-2.2/sources/poky/bitbake/bin:/home/younes/bin:/home/younes/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin"; export HOME="/home/younes"; LANG=C git -c core.fsyncobjectfiles=0 fetch -f --prune --progress git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent refs/*:refs/* failed with exit code 128, output:
fatal: https://git.eclipse.org/git/gitroot/tcf/org.eclipse.tcf.agent/info/refs not valid: is this a git repository?

ERROR: tcf-agent-1.5+gitAUTOINC+5ec928ddf6-r0 do_fetch: Fetcher failure for URL: 'git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent;branch=1.5_oxygen_bugfix'. Unable to fetch URL from any source.
ERROR: tcf-agent-1.5+gitAUTOINC+5ec928ddf6-r0 do_fetch: Function failed: base_do_fetch
ERROR: Logfile of failure stored in: /home/younes/workspace/ccimx6ulstarter/tmp/work/cortexa7hf-neon-dey-linux-gnueabi/tcf-agent/1.5+gitAUTOINC+5ec928ddf6-r0/temp/log.do_fetch.30302
ERROR: Task (/usr/local/dey-2.2/sources/poky/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb:do_fetch) failed with exit code '1'
NOTE: Tasks Summary: Attempted 1849 tasks of which 1836 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
/usr/local/dey-2.2/sources/poky/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb:do_fetch
Summary: There was 1 WARNING message shown.
Summary: There were 3 ERROR messages shown, returning a non-zero exit code.

Checking the tcf-agent.service shows that it isn't loaded and inactive:
‚óŹ tcf-agent.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)

Could you please help me to resolve this issue ?

Thanks in advance.

Younes
asked Feb 5, 2018 in Linux by YounesC New to the Community (22 points)

Please log in or register to answer this question.

1 Answer

+1 vote
 
Best answer
builds fine here, just tested, could be a temporary glitch
answered Feb 11, 2018 by LeonidM Veteran of the Digi Community (4,354 points)
selected Aug 8, 2018 by YounesC
...