Home/Support/Support Forum/Migration from 802.15.4 to digimesh
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Migration from 802.15.4 to digimesh

0 votes
I am current using Xbee S1 and willing to upgrade the firmware to digimesh to allow mesh networking. I was using ND in API frame to search nearby devices in 802.15.4 which returned the device detected and one additional frame in the end(which I checked to confirm that the network search has ended). Since I have migrated to Digimesh I am facing some problems to implement the same. In digimesh if I don’t pass a parameter after ND in the API frame I do not receive any additional frame like 802.15.4 firmware. After I tried adding some time limit parameter and updating, keeping value 0x20 for both, I observed that I am receiving only one device at a time. So if I have 5 devices it happens than many a times my ND response detects the same device multiple times. Same with DN and FN API frames. I know that increasing the time limit would be a better option but the value will differ for different number of devices to be detected. Is there any better solution than increasing the time limit?

Thank you for patient reading :)

Regards
-Onkar
asked Nov 1, 2017 in Embedded Devices by the0nkar New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
What firmware version are you working with?

What is the API frame you are sending?

Are you using sleep modes at all? If so, what are the values?
answered Nov 1, 2017 by mvut Veteran of the Digi Community (14,574 points)
I am using digimesh firmware on Xbee S1 and I am not using sleep modes at all. I am sending AT command ND API frame from XCTU
Can you please provide the API frame you are sending to the module?
...