Home/Support/Support Forum/Error installing Digi Embedded Yocto
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Error installing Digi Embedded Yocto

0 votes
Hi everybody,
I am new using Digi devices. I am trying to install Digi Embedded Yocto by following the steps in http://ftp1.digi.com/support/documentation/90001423_D.pdf
but when I do "repo init -u https://github.com/digidotcom/dey-manifest.git -b refs/tags/1.6.5" I have the following error:
Traceback (most recent call last):
File "/usr/local/dey-1.6/.repo/repo/main.py", line 506, in <module>
File "/usr/local/dey-1.6/.repo/repo/main.py", line 482, in _Main
result = repo._Run(argv) or 0
File "/usr/local/dey-1.6/.repo/repo/main.py", line 161, in _Run
result = cmd.Execute(copts, cargs)
File "/usr/local/dey-1.6/.repo/repo/subcmds/init.py", line 390, in Execute
File "/usr/local/dey-1.6/.repo/repo/subcmds/init.py", line 176, in _SyncManifest
r = m.GetRemote(m.remote.name)
File "/usr/local/dey-1.6/.repo/repo/project.py", line 679, in GetRemote
return self.config.GetRemote(name)
File "/usr/local/dey-1.6/.repo/repo/git_config.py", line 188, in GetRemote
r = Remote(self, name)
File "/usr/local/dey-1.6/.repo/repo/git_config.py", line 532, in __init__
self.review = self._Get('review')
File "/usr/local/dey-1.6/.repo/repo/git_config.py", line 668, in _Get
return self._config.GetString(key, all_keys = all_keys)
File "/usr/local/dey-1.6/.repo/repo/git_config.py", line 132, in GetString
return self.defaults.GetString(name, all_keys = all_keys)
File "/usr/local/dey-1.6/.repo/repo/git_config.py", line 129, in GetString
v = self._cache[_key(name)]
File "/usr/local/dey-1.6/.repo/repo/git_config.py", line 246, in _cache
self._cache_dict = self._Read()
File "/usr/local/dey-1.6/.repo/repo/git_config.py", line 253, in _Read
File "/usr/local/dey-1.6/.repo/repo/git_config.py", line 283, in _SaveJson
if os.path.exists(self.json):
AttributeError: 'GitConfig' object has no attribute 'json

Can somebody help me please?
Thanks :)
asked May 29, 2015 in Linux by digiConnectcore6 New to the Community (2 points)

Please log in or register to answer this question.

2 Answers

0 votes
looks like this is reported here with workaround:
or delete .repo folder and try again
answered May 29, 2015 by LeonidM Veteran of the Digi Community (4,362 points)
I deleted it and tried again but it didn't work.
I just forgot to register in git actually. After doing "sudo git config --global user.email "your@email" it worked.
0 votes
The updated Digi Embedded Yocto guide is now available at this URL: http://ftp1.digi.com/support/documentation/90001423.pdf.
answered Jan 4, 2016 by jlocke New to the Community (6 points)