Home/Support/Support Forum/Debian Jessie on Connect Core 6 ?
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Debian Jessie on Connect Core 6 ?

0 votes
Hello all,

I am still working on running Jessie on the ConnectCore 6, and I am facing several problems.
My first approach is to run the digi’s yocto kernel a Jessie rootfs. Kernel and init correctly start but:
• Udev cannot start. It claims the mandatory devtempfs is missing ;
• After a while (after starting the cron deamon) Init tries all runlevels (3, 1, 5, 6, 2, 4) and complains “(runlevel id) respawining too fast: disabled for 5 minutes”
I have tried to modify the inittab, without success. I cannot get back any terminal. It seems the new systemd replacing the old fashion initd requires the dbus running, relies on the udev, which previously didn’t start…
So I have tried to build a new linux 4.0.0 with the devtempfs, but it seems to lack some drivers and panics just after successfully mounting the mmc1blk2 ext4 image on the rootfs.
Here are my questions:
• Is there a Jessie distribution ready for the ConnectCore6?
• Where can I find a complete linux 4.0.0 kernel configuration?
• Are there specifics drivers that are not integrated on vanilla kernel?
• What more did I miss?

Thank you very much, any help is welcome,
asked Apr 15, 2015 in Linux by VRoqueta New to the Community (3 points)

Please log in or register to answer this question.

2 Answers

+1 vote
you can find Debian Jessie images for i.MX6 boards here:
some porting and device tree changes might be reqired to port to cc6 SBC

Digi Linux BSP is based on Freescale i.mx6 BSP and I do not think 4.0 Kernel has been ported to i.mx6 by freescale
some more info is here:
answered Apr 20, 2015 by LeonidM Veteran of the Digi Community (4,366 points)
0 votes
Sorry for the late answer.

I am afraid I didn't succeed to completely boot a Jessie distribution using these links.

Apparently the Kernel of the Digi's Yocto
runs some modified drivers I don't have on the vanilla 4.X ? In my understanding, the sdcard driver was modified and then I can not load it with the default driver ?

Is there a 4.0 linux support planned in the next months ?

answered Aug 5, 2015 by VRoqueta New to the Community (3 points)