Home/Support/Support Forum/X-CTU can not update firmware

X-CTU can not update firmware

0 votes
[:((] When I open X-CTU and choose a com port ,then I want to get my modules' version ,so I press Test/Query,but it always give the information :Unable to communicate with modem.
I press dowload new version from the web ,but ,after about 15 minutes ,it give me a message box saying :"The operation timed out ", download failed .
I have try this for many times ,but it still dosen't work . Now ,my xbee module neither can read nor can write.I really want to solve this problem . can you help me ?
my module version is Xbee Pro S2B,XBEE24B
THANKS.
asked Aug 15, 2012 in XCTU by mantou New to the Community (3 points)

Please log in or register to answer this question.

14 Answers

0 votes
The 'new version' issue is of course not related to the first issue. Worstcase, just get the latest files from the digi support site.

The Test/Query button will often fail if the Xbee's baud rate and API-setting is not the same as what you set into XCTU. XCTU does do some minor searching, but not much.

Worstcase, you follow these instructions and force your Xbee to reflash to a known state, which also restores the serial settings:
http://www.digi.com/wiki/developer/index.php/Bootloader_to_force_XBee_reflash
answered Aug 16, 2012 by lynnl Veteran of the Digi Community (1,047 points)
0 votes
dear lynnl,I have follow the steps,http://www.digi.com/wiki/developer/index.php/Bootloader_to_force_XBee_reflash
,but after I press a 'B '.my xbee give no responses,and my X-CTU is the latest version :5.2.7.5, I have no idea about it .can you give me another way to solve this problem? Thank you very much!!
answered Aug 18, 2012 by mantou New to the Community (3 points)
0 votes
I normally follow these step in case of failure or corrupt firmware.

1) connect Xbee on Development board
2) Go to Modem Configuration menu and select right firmware in model
3) Once right firmware is selected tick always update firmware
4) Press reset button on the development board (do not release)
5) select write and wait until reset info windows appears and then release reset of the development board.

It should work for you..

Regards,
Pathik
answered Aug 21, 2012 by pathik New to the Community (8 points)
0 votes
Hi,

Give a try with below steps

-Unplug power cable,
-Go to Modem Configuration tab, select proper Modem and Function set and Version,
-Enable "Always Update Firmware"
-click "Show Defaults"
-click "Write"
When the "Action Required Window pop-up" appears plug the cable and see if it writes the firmware
answered Aug 22, 2012 by kavya Seasoned Professional (198 points)
0 votes
Still no luck try this:

(a) Download and install latest X-CTU from the downloads section.
(b) Power off your module.
(c) Put reset to ground, or activate reset switch in your test board.
(d) While powered off (yes!) start the update on X-CTU and wait until it complains that a reset is needed.
(e) Power on your board, and after a few seconds, release reset.
(f) Update should start.
answered Aug 22, 2012 by kavya Seasoned Professional (198 points)
0 votes
And here’s a recipe that was posted by NATP who says it has worked for him:
(a) Using the USB board (XBIB-U-Dev rev 3), X-CTU 5.2.5.0 with Windows XP, SP3
(b) Close X-CTU, disconnect the board
(c) Power on the board
(d) Open X-CTU
(e) On the PC-Settings tab:
• Set Baud Rate to 38400
• Select “No baud Change”
(f) Click Test/Query - this will fail with the “action required” dialog... - close it when it comes up (do not follow
the instructions on the dialog)
(g) Click “OK” to the “cannot find modem” dialog
(h) On the PC-Settings tab:
• Set Baud Rate to 9600
• Un-select “No baud Change”
(i) Click Test/Query - Success!
(j) On Modem Configuration Tab – click “read” – Success!
answered Aug 22, 2012 by kavya Seasoned Professional (198 points)
0 votes
If none of the above works, contact Digi Technical Support.
Create an Online Support Request at the following link, http://www.digi.com/support/eservice/login.jsp
answered Aug 22, 2012 by kavya Seasoned Professional (198 points)
0 votes
If you issue is solved then please update the forum so that other users of forum can make use of your solution
answered Aug 23, 2012 by kavya Seasoned Professional (198 points)
0 votes
,Dear kavya:
I am soory ,I have not logined for a long time ,so I have not seen your answers ,Thank you for giving me so many methods .I have try the first method ,but it failed. I have three modules , only one suceed with the third method .but there comes another problem , when click Test/Query ,it appears modem type=XBP24BSE,butif I click read ,it appears ,the modem type is XBP24BZ7,why the two type is diffirent? Buy the way ,the type behind my xbee is XBP24BZ7,what's the correlation between the three? Look forward yours answers.Many thanks.
answered Sep 9, 2012 by mantou New to the Community (3 points)
Mantou,

That would indicate that you have installed the Smart Energy firmware on the module in question. That means that if you want to talk to it, you will need to enable the API function on XCTU PC Settings tab.

If you do not want to use the Smart Energy Code, then I would suggest re-loading the standard ZB code on by first selecting the Modem type XBP24BZ7 and then the desired function set and firmware version.
0 votes
Hi mantou

This seems to me as a bug in X-CTU. This happens with my S2B module as well.

But don't worry, it doesn't create any issue. The correct modem type is what you get when you hit "Read". Most probably, folks at digi will remove this bug in future updates of X-CTU.
answered Sep 10, 2012 by asgm Veteran of the Digi Community (1,497 points)
...