Home/Support/Support Forum/DIN kit, dia.py overwrites sleep time settings
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

DIN kit, dia.py overwrites sleep time settings

0 votes
Hi all,

We are starting with Digi and testing with Connectport X4 and some router and end node sensors. Basically we are using sample software provided by Digi with the kit. I'm sure this question will be very basic fro you, but are unable to find out where our problem is.

The doubt is following: Using dia.yml we configure the devices, and using the X4 gateway web interface we stablish sleep mode for those end nodes, but for some reason we do not detect, the cycling sleep period and time sleep are "self" changed. I have detected that the "process" that overwrites my settings is XbeeConfigBlockDDO.apply_config.

We are using default xbee_sensor.py driver from Digi.

This happens only with Digi devices. We are testing also other sensors from Pikkerton and with this devices (and their drivers9 we do not have the problem.

Any idea?

Thanks in advance for your time and help!

Note: I have opened a ticket for this, but no news from Digi, so I come here to request the community help.
asked May 26, 2011 in Python by bruixian New to the Community (6 points)

Please log in or register to answer this question.

6 Answers

0 votes
Yes, Dia by default assumes a lower bar on pre-configuration of XBee devices than the one that you have set. It uses configuration information from the dia.yml file to set the sleep for devices accordingly.

There are a couple things that I can recommend looking into that may help, both in the configuration of the 'xbee_device_manager' https://developer.idigi.com/edocs/documentation/user/devices/xbee/xbee_device_manager.html

The first sounds like the best for you. If you are configuring the devices appropriately and independently, you can inform dia of this with the 'skip_config_addr_list'. Add the MAC of your XBee sensor to this list, and Dia will not attempt to configure it.

A similar approach is to let Dia configure it once. If you set the 'update_skiplist' setting to True (If it's not already), it will configure the device and after doing so update the skiplist so that it does not configure the device again.
answered May 26, 2011 by DigiGuy42 Community Contributor (102 points)
0 votes
Hi,

Thanks DigiGuy24 for the tip. I'm going to make a look right now.

Regards,

Bruixian
answered May 26, 2011 by bruixian New to the Community (6 points)
0 votes
Yes, for most Digi products, the Dia forces changes to sleeping settings. For example, the LT/LTH Sensor driver has a required settings called 'sample_rate_ms' which will be downloaded to the device.

The only solution is to either modify the xbee_sensor.py file, or make use of the skip_config_addr_list setting of the xbee manager (see below). This cause the Dia to set NOTHING in the device, but is also causes Dia not to understand how to set the SN/SP parameters of the X4 and routers correctly for sleeping end-devices.

- name: xbee_device_manager
driver: devices.xbee.xbee_device_manager.xbee_device_manager:XBeeDeviceManager
settings:
skip_config_addr_list: [ "00:13:a2:00:40:4a:6e:83!", "00:13:a2:00:40:32:14:FA!"]
answered May 26, 2011 by lynnl Veteran of the Digi Community (1,047 points)
0 votes
Hi,

Thanks Lynnl fr the tips. Please let me question: what do you mean when you say: "but is also causes Dia not to understand how to set the SN/SP parameters of the X4 and routers correctly for sleeping end-devices"? Does that means that if I add the devices to the "skip_config_addr_list" and then I change sleep time on the X4, this changes will not take effect? If so, how can I set the sleep time to the LHT?

Thanks,

Bruixian
answered May 26, 2011 by bruixian New to the Community (6 points)
0 votes
Correct. The "skip_config_addr_list" setting tells the framework to complete ignore trying to configure the sensor because YOU already did it yourself.

It is your typical all or nothing. Either you want Dia to manage your LTH settings, or you do not.

You can always temporarily change the YML to force a new update, then restore the "skip_config_addr_list" setting
answered May 31, 2011 by lynnl Veteran of the Digi Community (1,047 points)
0 votes
Well, I added the devices to the "skip_config_addr_list" and, as you can spect, I don't have the problem any more. Thanks both of you!

Best Regards,

bruixian
answered May 31, 2011 by bruixian New to the Community (6 points)
...