Home/Support/Support Forum/NET+OS7.3 and new Flash chips
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

NET+OS7.3 and new Flash chips

0 votes
We've been running simple devices with the connectcore 9p9215 on 7.3 for the last decade or so. The original software engineer left.
Two years ago we got the flash change notice for v7.5. An support engineer was so nice to send me the flashparts.c & h to patch v7.3 manually.

Today we received our first batch of changed connectcores and as it turns out the patch doesn't seem to work. (I get the blinking LEDs on the module after I start the debugger)
The part found on those is enabled in flashparts.h (EON EN29LV320CB)

I CAN'T JUST UPGRADE TO 7.5 RIGHT NOW (too many changes to our codebase).

Has anyone successfully patched 7.3?
asked Aug 16 in Other/Legacy by kay New to the Community (5 points)

Please log in or register to answer this question.

2 Answers

0 votes
OK .. one step further. It seems I also need to swap out Flash.h (from a 7.52 install)
And also replace the flashparts.h in your project (it gets copied over there on creation)

.. for now it seems I can run our stuff on the new flash-IC modules.
answered Aug 17 by kay New to the Community (5 points)
0 votes
Hello Kay
I too have a similar situation. Our code is for the same core, a CC9215, is also based on 7.3.
Now, our code doesn't work with the latest chips.

Could you send me the files I need to patch our code please?

Dave
answered Sep 16 by davidnorman New to the Community (5 points)
...