Home/Support/Support Forum/TLS V1.2 STATUS_UNSUPPORTED_CIPHER
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

TLS V1.2 STATUS_UNSUPPORTED_CIPHER

0 votes
Just a brief question I hope someone can help....No answer on the forum similar question. Several of our connections to various public servers are failing and it appears that it is related to TLS V1.2. I have installed all of the latest updates via package manager and created a new project to test this without success.

ssl.h shows nothing for V1.2 however there is a forum answer from digi that states V1.2 is supported in NET-OS. Apple push notifications now require TLS 1.2 to connect along with NOAA weather servers.

Secure connection attempts return a -2 (SSL_UNSUPPORTED_CIPHER)

Is there some define I am missing or other issue I may have missed?
Package manager states that it is using OpenSSL V1.0.2.e which seems to reflect it has TLS 1.2.

Thanks for any help.....I've already spent 2 days troubleshooting this.....

Brooks
asked Mar 16 in NET+OS by bdorroh New to the Community (32 points)

Please log in or register to answer this question.

2 Answers

0 votes
Brooks,

Please contact Digi Support by sending an email to tech.support@digi.com
answered Mar 17 by mvut Veteran of the Digi Community (14,670 points)
0 votes
This was answered via support case. Neots does include openssl 1.0.2e which does support TLS 1.2. There are 2 sample apps, openssl client and openssl server that demonstrate TLS 1.2 connectivity with openssl server/client on Linux side. SSH server that ships with Netos was not updated and does not support TLS 1.2.
answered Mar 19 by LeonidM Veteran of the Digi Community (4,355 points)
...