Home/Support/Support Forum/UDPDB Not working
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

UDPDB Not working

0 votes
Hi,

In debug mode I want to log events using the UDP Debug feature. For this I modified the following
in <bsp_sys.h>
#define BSP_STDIO_PORT "/udpdb/0"
#define BSP_UDP_DEBUG_PORT 12345


in <bsp_drivers.h>
#define BSP_INCLUDE_UDP_DEBUG_DRIVER TRUE

For each event I want to log I added a printf("...");

I rebuilt the BSP & application, but in the UDPDB tool nor in the ESP UDP Window, I don't see any messages coming in.

I use a ConnectME and Net+OS 7.5

What did I overlook?

Thanks for your reply,
Kris
asked Nov 6, 2020 in NET+OS by kdemets New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
I've just created a tested a new project with udpdb enabled and it works out of the box:
E:\Netos75\bin>udpdb 192.168.1.119 Retrieving debug data from unit at 192.168.1.119, UDP debug port 12345. IAM:AUTO-CONFIGURED IPv6 FE80::240:9DFF:FE3B:7A7F on eth0:3
IAM:AUTOIP IPv4 169.254.226.217 on eth0:0 IAM:DHCP IPv4 192.168.1.119 on eth0 Network IP configured. FTP Server Sample Ready.

please make sure you can ping the target, and that you pass the correct IP address to udpdb. Also please make sure firewall and antivirus are not blocking udpdb on your PC.
answered Nov 6, 2020 by LeonidM Veteran of the Digi Community (4,042 points)
Hi Leonid,

Thanks for your reply. The out of the box example does work indeed.

First of all, I had to modify a line in appconfig.h
/**
#define APP_STDIO_PORT "/com/0"
**/
#define APP_STDIO_PORT "/udpdb/0"

Next, when I want to make use of the serial portA as additional communication device, the printf() statements generate data into the void.(Before opening the serial port for communication, printf() is routed nicely to the UDPDB.) Replacing the printf() statements by

ccode = udpdb_write(0, msg, strlen(msg), &size);

does the trick (and is way faster than using printf())

However, I still don't know why that is.

Best regards,
Kris
...