Home/Support/Support Forum/Does anyone know how to get RTSP working on a WR21
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Does anyone know how to get RTSP working on a WR21

0 votes
I have the port forwarding set up to pass port 554 our to Ethernet 1.
External Min Port: 554 External Max Port:554 Forward to Internal IP Address:192.168.69.101 Forward to Internal Port: 554

I also have a firewall rules setup:
pass in break end proto tcp from any to any port=544
pass in break end proto udp from any to any port=544
pass out break end inspect-state

there are other rules but those are the pertinent ones.

when I try using VLC to get the stream from the camera attached it does not work. The fire wall shows no hits on the rules.

I am use the command type:rtsp://username:password@ip_address:554&subtype=0 with the appropriate username and password and the public ip add of the WR21

Any suggestions?
asked Oct 9, 2020 in Digi TransPort by dbweiner New to the Community (15 points)

Please log in or register to answer this question.

4 Answers

0 votes
Is the public IP reachable, can you ping the modem and access the web interface of the WR21 modem remotely?

If you can reach the modem then check to see if Enable NAT on this interface is selected in the Mobile Interface Network settings, and also that IP address and Port are selected.
answered Oct 17, 2020 by Bryonhu Seasoned Professional (195 points)
0 votes
The public IP is reachable. The NAT is enabled and IP address and Port are selected. I have also tried with the appropriate firewall rules HTTP and that works. The issue is getting rtsp protocol to work.
answered Oct 17, 2020 by dbweiner New to the Community (15 points)
0 votes
You would need to configure a multicast route.
The camera will have multicast stream settings and you'll need to add the multicast address in use into the router config.

Configuration - Network > IP Routing/Forwarding > Multicast Routes
Set a multicast route towards the source of the multicast traffic, I’ll assume this is Eth 0.
Set the multicast address and mask, and the interface to route traffic to the multicast source then click ‘add’.

You'll need to enable IGMP (multicast) on the interface closest to the device requesting the stream, this will probably be PPP 1 in your case.
This is a CLI option only.
ppp 1 igmp on

Disable the firewall to test, this will check if IGMP is working without potentially being blocked.

It may be simpler to use a UDP or HTTPS stream instead.
answered Nov 3, 2020 by bengartland Seasoned Professional (169 points)
0 votes
Thanks bengartland I will give it a try.
answered Nov 3, 2020 by dbweiner New to the Community (15 points)
...