Home/Support/Support Forum/Xbee Failing to Communicate in API Mode

Xbee Failing to Communicate in API Mode

0 votes
Relatively new to this, so bear with me if this is a silly problem. I have two XBee Zigbee 3s in API Mode, and I cannot get them to see each other when scanning in XCTU. Parameters are:
Coordinator:
CE - Form Network
JV - Disabled
NI - Coordinator
OP - F2899CD1CD573C54
CH - 19
DH - 0
DL - 0
SM - No Sleep
SP - 1F4
AP - API Mode without Escapes
Baud Rate - 9600
Firmware 100A

Router:
CE - Join Network
JV - Enabled
NI - Router
OP - F2899CD1CD573C54
CH - 19
DH - FFFF
DL - FFFF
SM - No Sleep
SP - 1F4
AP - API Mode without Escapes
Baud Rate - 9600
Firmware - 100A

When scanning in XCTU, there is a gray arrow between the two units, indicating the router is not talking to the coordinator.
asked Sep 28, 2020 in RF Solutions and XBee by elizabeth.farrell New to the Community (3 points)

Please log in or register to answer this question.

2 Answers

0 votes
You need to have Joining enabled on the Coordinator to allow a router or end device join it. Once it is Joined and AI shows such, then you can disable joining.
answered Sep 29, 2020 by mvut Veteran of the Digi Community (14,777 points)
Thank you for your help! You say I need "Joining" enabled - are you talking about the JV parameter?
No, I am referring to NJ.
NJ is set to FE - 254 seconds.
May I suggest you send an email to tech.support@digi.com.   Make sure you include firmware versions, settings and images of what you are seeing.
0 votes
if your scanning from master node , please make change in DL= FFFF,and Keep Router DH=0 and change JV= Disable in both and try once, i think it will slove your problem
answered Oct 1, 2020 by csreddy Seasoned Professional (195 points)
DL and DH have nothing to do with being able to Join a network. They have to do with sending data packets.
...