Home/Support/Support Forum/Error discovering neighbors of <mac>

Error discovering neighbors of <mac>

0 votes
This keeps happening to me and when it does I seem to have to "flatten" all settings, reapply firmware to be able to get things working again.

I set up a coordinator and a router set to AP [1] and when I scan the radio network both of them show up and are connected.

I then go through the process of changing them over to micropython and add code so that they talk to each other, still fine and connecting to each other.

This is where I think something is going wrong. I change the sleep mode or the router to Micropython Sleep [6] and edit my code so that it does go to sleep and wake on a contact closure but then it will not connect to the coordinator when it wakes up.

From this point on, if I change the sleep mode and the AP back to [1] then in XCTU I get

Error discovering neighbors of <mac>
Cannot find the local device of <mac> address.
Remove it from the Radio Modules list on the left and add it again.

That doesn't resolve anything and I have to go down the route of "flattening" it again.

Is there something that I am missing with regards to activating MicroPython Sleep?

It's not that it isn't waking up again, it is. And even if it was, if I change that mode back and AP to API mode then this should stop it from sleeping.

I'm about to start again to try and pinpoint the exact moment that it breaks but any ideas as to what is happening would be welcomed.
asked Sep 12 in XBee3 by tdg New to the Community (14 points)

Please log in or register to answer this question.

3 Answers

0 votes
In fact, when I get to this state I can't easily get it back again.

I set it to default settings, reinstall firmware, change USB ports and reboot my laptop. Not one of these things brings it back but some seemingly random sequence eventually does.
answered Sep 12 by tdg New to the Community (14 points)
0 votes
OK, tested again and it works right up to the point where I set the Router to MicroPython Sleep [6] and it becomes an endpoint.

I've not changed any other settings and that one action goes from the 2 XBees talking to each other to not.

Is there something else I have to do to an Endpoint as opposed to a Router?

I thought the sleep setting was the only difference between the 2.
answered 6 days ago by tdg New to the Community (14 points)
0 votes
I found out why this was happening so I hope this helps someone else save the time I wasted.

I was using Zigbee firmware. You can still set the sleep mode to MicroPython in XCTU but it doesn't look like it is supported.

I'm now using Digimesh firmware and it now works as expected.
answered 4 days ago by tdg New to the Community (14 points)
edited 4 days ago by tdg
...