Home/Support/Support Forum/XBee 3 Coordinator - Never remove End Device

XBee 3 Coordinator - Never remove End Device

0 votes
Hello everyone.

I have a system that includes an XBee 3 coordinator, an XBee S2C end device and several end devices from third party.

The coordinator uses NJ=0 when there is not a joining request. The sensors are included in the network by using Register Joining Device (0x24) frame.

The problem is:
I remove the coordinator out of range of the sensors and wait for a couple of hours or even days. All sensors are removed from network. After the coordinator is again in the range of sensors, the third party sensors connect the coordinator but the XBee S2C end device does not. I need that XBee S2C end device also connects the coordinator.

What I tried:
I am aware of rejoining mechanism but i do not want to use the limitations of rejoninig mechanism (like using association instead of rejoining if there are multiple rejoning request without success).
Things I tried includes using a fixed PAN ID, setting DC bit 5 and NW>0 (allow rejoining mechanism), varying sleep options including ET command.

I think the problem is in both XBee 3 coordinator and XBee S2C en device. The ET register of the coordinator defines the end device timeout even though the description of that register says 'it is only set on the SED (sleepy end device)'. After ET minutes has passed, the XBee S2C end device is removed from network.
On the other hand, the end device forgets its parent after 3 failed transmissions even though DC bit 5 is set and there is a fixed PAN ID.

Sum up:
I need an XBee S2C end device and XBee 3 coordinator that are bound. End device must never forget its parent and when disconnected from coordinator it must always use rejoining mechanism. Coordinator must never remove end device from child table and must be able to identify it after a lost connection.

Are there such algorithms or settings that I can use?
Have a nice day.
asked Aug 18, 2020 in XBee3 ZigBee by brkns New to the Community (3 points)

Please log in or register to answer this question.

1 Answer

0 votes
What you will need to do is enable Joining on the Coordinator.
answered Aug 18, 2020 by mvut Veteran of the Digi Community (14,666 points)
I tried enabling joining on coordinator by setting NJ=0xFF. But there is no success. I have to also set the custom KY value on the coordinator that I embed in the XBee S2C end device to achieve what I wanted but it creates security problems.
I register that end device to coordinator using the register joining device frame with option 0x00 (use link key). I did not understand how third party devices easly reconnect to network and XBee S2C end devices can not.
You need to look at the EO options bits you are using on both the Coordinator and End device. Make sure you are using the proper values.

Also make sure you are using the proper firmware. That is they both should be using the same version or at least function set.
I tried it but no success. Switching XBee 3 for the end device too.
I would suggest at this point for you to contact Digi Technical Support by sending an email to tech.support@digi.com.   Make sure you include the configuration files for the modules you are working with.
...