Home/Support/Support Forum/configuration IP
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

configuration IP

0 votes
Hi, I would like use a ip static to do a ping between my card BL4S100 and my computer but same after trying pingme.c (and changed with correct values and sentence) my ip stay at 169... (APIPA IP)/ So I would like know what I need to configure correctly my IP. Thank you
asked Aug 17 in Rabbit by JPal New to the Community (7 points)

Please log in or register to answer this question.

2 Answers

+1 vote
//You need to specify a static address either in your program or on the Define Window under the Project Options menu.//

//Make sure that your define TCPCONFIG in your program is set to "1" as the define below. //

#define TCPCONFIG 1

//Then you need to add the below statement with the correct ipaddress you want to your Define window under Project Options.//

TCPCONFIG = 1;
_PRIMARY_STATIC_IP = "10.10.6.100";
_PRIMARY_NETMASK = "255.255.255.0";
MY_GATEWAY = "10.10.6.1";
MY_NAMESERVER = "10.10.6.1";
answered Aug 17 by Campbell Veteran of the Digi Community (742 points)
+1 vote
Are you talking about setting the IP of the BL4S100, or of your computer? @Campbell's answer below explains setting it on the Rabbit, but it sounds like you might also need to set it on your computer.

For Windows, go into the network settings, find your Ethernet interface, and configure it for a static IP instead of DHCP (the default setting). This assumes you're using Wi-Fi for your network connection, and connecting the Rabbit directly to the PC's Ethernet port.
answered Aug 17 by TomCollins Veteran of the Digi Community (2,051 points)
Hello, for begin thanks you for these answers,

For this code :

#define TCPCONFIG 1

//Then you need to add the below statement with the correct ipaddress you want to your Define window under Project Options.//

TCPCONFIG = 1;
_PRIMARY_STATIC_IP = "10.10.6.100";
_PRIMARY_NETMASK = "255.255.255.0";
MY_GATEWAY = "10.10.6.1";
MY_NAMESERVER = "10.10.6.1";

I have all this yet, I changed all settings to match my computer but when I tried to do a ping of my new IP static with the same netmask and gateway than my computer, it doenst work. So maybe I missed something.
For the second answer :
"For Windows, go into the network settings, find your Ethernet interface, and configure it for a static IP instead of DHCP (the default setting). This assumes you're using Wi-Fi for your network connection, and connecting the Rabbit directly to the PC's Ethernet port."

I have done all this but doesn't work too ;(. When i check my new IP it's APIPA and I have the constraint not to use the DHCP in my program.

Have you a other solution. To be sure all is correct normaly with ipconfig of my Ethernet I must see my IP configuration but I have a APIPA IP.

Thank you for these answers again ! if you have a other idea tell me !
Since you reference ipconfig, I assume you're talking about your computer.  If you have an APIPA (169.254.x.x) address, then you don't have the network interface on your computer configured correctly.  You'll see an address like that if configured for DHCP and the computer can't connect to a DHCP server.  So double check your computer's configuration.  The Rabbit is probably fine.
Hello Tom,
Thank but i have found the solution it was it :" If you are doing a direct connect which does not have a hub in between you will need a crossover cable.  If you do not have a crossover cable you will need to connect a cable from pc to a hub and then another cable from Rabbit to same hub as pc is connected.  Please verify the hardware, cable and hub are working."
Interesting!  I was going to recommend trying that, but figured that all PC Ethernet interfaces would support "auto MDI-X" and work with either regular or crossover Ethernet cables.  Glad you figured it out.  You might want to add that information as another "answer" to this question and mark it with the checkmark, so someone else finding their way here via a search can easily find the solution.
...