Home/Support/Support Forum/naSslNgConnect blocking issue on ConnectME-C
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

naSslNgConnect blocking issue on ConnectME-C

0 votes
I am using the DigiESP (latest patched version) to compile code for a ConnectME(custom firmware). We have seen a lot of issues connecting to an SSL socket, when there are intermittent internet connection issues. I am trying to solve it in a lot of different ways but the two issues that I see are:
1. naSslNgConnect cannot use non blocking sockets
2. naSslNgConnect(and possibly sockets on NETOS/ThreadX) are not thread-safe (if I terminate the underlying TCP socket, sometimes the ConnectME will crash)

This is a problem that has been at the core of NETOS since very early on, and I have been trying to solve it in many different ways. The underlying issue is that if your TCP socket gets terminated while you are inside the naSslNgConnect(), there is no guarantee that this method will return back (could possibly block forever).

Please either patch naSslNgConnect() (I assume it's shared code from openssl) or let me know what can be done!!

Thank you,
Eran
asked Jun 15 in Embedded Devices by ebernste1234 New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Take a look at this previous thread, if this doesn't help you should open a support ticket.

https://www.digi.com/support/forum/69115/net-os-nasslngconnect-issue?show=69115#q69115
answered Jun 15 by Campbell Veteran of the Digi Community (683 points)
Nope. That issue is with two-way verification.
...