Home/Support/Support Forum/Enabling MULTICAST causing problem for wifi interface in imx6ul sbc pro
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Enabling MULTICAST causing problem for wifi interface in imx6ul sbc pro

0 votes
Hai,

We have an custom board for imx6ulsbc pro SOM module and I am running digi yocto in that.Now I want to do a MULTICAST operation over wifi so I have enabled in the kernel and builded the image.After flashing the builded kernel image I was not able to get the wifi interface up.But my previous kernel image is without MULTICAST with that wifi interface is working fine.I want to get the information how to enable the MULTICAST and get the wifi interface running successfully.

Regards
Srikanth.
asked May 27 in Linux by ckanth New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
What exactly are you enabling in kernel?
answered Jun 4 by LeonidM Veteran of the Digi Community (3,622 points)
Hai,

  Thanks for the reply the path I went in the menuconfig of the kernel is as follows and enabled multicasting.
   Networking support  --->
     Networking options  --->
       IP: multicasting.

Regards
Srikanth.
do you need IP multicasting on wifi interface?
Hai,

  Yah I want to do multicasting on wifi.

Regards
Srikanth.
Are you using DEY-2.6r3? Are there any errors or messages about radio when module boots? Are you trying this on SBC or custom hardware? Are you changing anything else in the kernel or device tree?
Can you please create a new Yocto project, build it without making any changes, and make sure wifi works. Then only modify Kernel config to contain CONFIG_IP_MULTICAST=y
and rebuild again and test again. Does Wifi work?
If not, please open a support case and attach a file generated by the sysinfo command on an SBC with non-working wifi.
...