Home/Support/Support Forum/error include 'ERRNO.H'/'XMEM.H' cannot be found?......
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

error include 'ERRNO.H'/'XMEM.H' cannot be found?......

0 votes
line 12 : ERROR MUTIL.LIB : 'ERRNO.H' cannot be found.
line 709 : ERROR STDBIOS.C : 'XMEM.H' cannot be found.
line 1987 : ERROR STDBIOS.C : Unexpected token in label : "_GEN_LIN2SEG >>> ( <<< b)", expected one of { ':' }
line 2092 : ERROR Rabbitbios.c : Unmatched '#asm'.


BL4S1XX board is used

for any example you have

C: \ DCRABBIT_10.72D \ Samples \ BL4S1xx


Before these examples ran well with DCRABBIT 10.70 ..

Now nothing compiles well
asked Feb 2 in Rabbit Software by siselentecnica New to the Community (2 points)
reshown Feb 3 by rmaroun

Please log in or register to answer this question.

2 Answers

0 votes
Verify your installation, I would uninstall all DC versions and re-install
answered Feb 3 by Campbell Veteran of the Digi Community (684 points)
Perfecto !

Gracias
0 votes
I have another problem with version 10.72D

When compiling the project you cannot find the .Lib files
(with version 10.70 and perfect).

The program uses this line:
#use xxx_MEM_2013.Lib

give this error;
line 348: TEST ERROR2_2013.C: 'xxx_MEM_2013.Lib' cannot be found.

** .Lib files were hosted on
C: \ DCRABBIT_10.72D \ Lib \ Rabbit4000

"Project Options" included Path
C: \ DCRABBIT_10.72D \ include
C: \ DCRABBIT_10.72D \ Lib \ Rabbit4000
C: \ DCRABBIT_10.72D \ Samples \ BL4S1xx \ Ale25_02_2013 (this is where the xx.C file is)

I reiterate with DCRabbit10.70 everything works
In 10.72D you cannot find the .Lib

Should they be staying somewhere else?

Gracias

////
THE ARCHIVE IS WITHIN

** .Lib files were hosted on
C: \ DCRABBIT_10.72D \ Lib \ Rabbit4000 ..xxx_MEM_2013.Lib
where are the .lib files

in version 10.70 it's going well.
But in version 10.72D it gives ERROR, as if it were not as I already explained
answered Feb 6 by siselentecnica New to the Community (2 points)
edited Feb 6 by siselentecnica
sounds like the library xxx_MEM_2013.lib needs to be moved into this directory. C: \ DCRABBIT_10.72D \ Lib \ Rabbit4000\   DC standard libraries have a name of mem.lib
Your "Include Path" in the Project Options should just be one line:
.\include

Libraries are configured in the file LIB.DIR of the compiler's installation.  You probably modified this file in your 10.70 installation, and didn't make similar changes to your 10.72D installation.
...