Home/Support/Support Forum/Why does XCTU discover and communicate with remote nodes only when their DIN pin is high?

Why does XCTU discover and communicate with remote nodes only when their DIN pin is high?

0 votes
I want to use XBee with only SPI and turning off UART (which I am not sure how to do). For this, in I/O settings in XCTU, I set pins 4, 11, 17, 18 to work in SPI equivalent pins and then connect corresponding pins to an SPI bus of a raspberry pi. After this sending data from that SPI-enabled xbee to a local one connected through a usb adapter to XCTU works, as I can see received data in the console of XCTU. But reverse transmission - sending data from console to the remote one doesn't work (Transmit Status: Delivery status 24 (Address not found),Discovery status 00 (No discovery overhead)), neither XCTU discovers the remote node. Only accidently I noticed that connecting DIN to TX of raspberry pi (actually to any 3.3V source) makes it possible to be found by XCTU and with the pin connected reverse transmission also works.

I also tried turning off DOUT/DIN (2,3) pins by choosing "Disabled[0]" for P3, P4 configurations in XCTU hoping this would turn UART off but keeping SPI pins enabled. After this even connecting DIN to high didn't work, moreover it was impossible to find it in XCTU by connecting through usb adapter like it was dead. Maybe it has something to do with DIN pin as it is also CONFIG pin as described in datasheet and disabling it leads to inability to configure it with XCTU? Then how to turn off UART properly without needing to connect DIN to high and keeping SPI enabled?

Currently, I ended up by sending AT commands over SPI from raspberry to restore defaults, write them and reset which allowed to see it in XCTU (as pin 2,3 is set to DOUT,DIN by default). In such situations, I am also able to use "XBee recovery" from XCTU and it restores defaults.

What I also noticed is that disabling DIN, DOUT pins keeping SPI pins disabled still allows to configure xbee with XCTU. Only when ALL SPI pins 4, 11, 17, 18 are disabled, disabling either DIN or DOUT leads to inability to find xbee by usb.

Both xbees work in API mode, with the same PAN ID and configured DL, DH adresses.
Product family: XB24C (S2C)
Function set:ZIGBEE TH Reg
Firmware version: 4060
asked Aug 7 in RF Solutions and XBee by turok1997 New to the Community (0 points)

Please log in or register to answer this question.

Contact a Digi expert and get started today! Contact Us
...