Home/Support/Support Forum/HART Protocol via RS-232
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

HART Protocol via RS-232

0 votes
Using BL2100. Attempting to communicate with a HART-enabled sensor system through a HART-RS232 modem (converter manufactured by Raytek). Sensor is not responding. I am sure that the sensors works since when the HART-RS232 is used in conjunction with the configuration software that came with the sensor, the sensor responds. However, when I connect the HART-RS232 back to the BL2100, somehow, SerXputs does not work. I looked at a few code examples for Dynamic C, and I saw a command "SerMode(0)" which I could not find a reference on any documentation I have on hand. I think I may be missing some critical communication setting and perhaps I should be setting "Serial Mode" as another type (i.e., not "0"). Need help on this. Willing to engage a consultant to get this done. Please contact me (+1.281.844.2275 Victor, Houston USA) or e-mail me (victors@absmartusa.com) your contact number so I can call. Thanks.
asked Jun 12 in Modbus and Industrial Automation by bixdsaet New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Sorry, don't know anything about BL2100, but make sure any RTS/CTS flow control is as the HART device expects. I assume HART has very small packets, so even if you don't want to deal with RTS/CTS, make sure your 'assert' the GPIO to indicate to the HART device assumes sending is always okay.
answered Jul 18 by Coralyn Community Contributor (143 points)
Contact a Digi expert and get started today! Contact Us
...