Home/Support/Support Forum/Xbee programmable module not recognized by the XCTU software

Xbee programmable module not recognized by the XCTU software

0 votes
Hello,

I have been looking to program my xbee modules and interface LCD with it. But there have been issues with xctu not decting them.

1. Firstly, xctu software detects the non programmable versions of xbees easily but when i try to connect the programmable xbees, the xctu recognizes them rarely. I have to hit the reset and commissioning button multiple times.I have tried setting different baud rates but it does not work. Any idea why that happens?

2. Secondly i wanted to ask that is it possible for the programmable xbee to be programmed using the xbee groove development board or it is only possible with the development kit and a debugger connected to it.

Xbee part no. XB24CZ7PISB003-revJ


regards,
Mustafa
asked Jan 25, 2018 in RF Solutions and XBee by khawaja.mustafa New to the Community (3 points)

Please log in or register to answer this question.

1 Answer

0 votes
Yes that is correct. The reason for that is that you need to have the proper code on that processor for XCTU to access the RF processor. Otherwise it has to try at different baud rates.

While you can port an application via the UART, if you mess it up at all for any reason or do not include , you are then required to do it via a debugger/programmer.
answered Jan 25, 2018 by mvut Veteran of the Digi Community (11,300 points)
Thanks a lot for the help.
1.Which proper code are you referring to, that enables the XCTU software to detect the RF processor.

2.Yes it works fine if we transfer the .bin file using the old xctu version. But any idea how to clear the code we have loaded. It kind of looks like a single time use.

Regards,
You need to write/compile and port over via a BDM programmer a transparent application from Code warrior.
...