Home/Support/Support Forum/Does anyone use Point Six wireless sensors with a ConnectPort gateway?

Does anyone use Point Six wireless sensors with a ConnectPort gateway?

0 votes
Hi... we're trying to use a ConnectPort X2 gateway with wireless sensors from PointSix. All of them use identical XBee modules, which are the 900Mhz S3B version.

I've verified that the gateway can "see" packets from the sensors by changing the channel and PAN ID of the Digi to match the PointSix configuration. I can see the packets, but I don't have a way to decode them.

I can probably muddle my way through decoding them using scripting on the gateway, but since that won't solve the problem of getting the sensor data from the gateway into our BMS, I thought I'd ask here.

Has anyone done such a setup with the PointSix and a Digi gateway, preferably with a way for another device to query the ConnectPort using SNMP, BACnet, or Modbus to retrieve the sensor data?

Thanks,
Erik
asked Oct 9, 2017 in Linux-based Gateways by erikg New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Erik,

This is something you really need to ask Point 6. That is what or how to read their data and decipher it. Then you can decided how to write the Python code to convert it to what ever protocol you desire.
answered Oct 9, 2017 by mvut Veteran of the Digi Community (11,298 points)
I actually have asked Point 6.  I have a fairly good idea on the packet format, it's mostly in the Point 6 manuals.

I was just hoping someone else had already written the code to decode them.
...