Home/Support/Support Forum/cannot comunicate between 2 xbee

cannot comunicate between 2 xbee

0 votes
Hi there, I currently have two arduinos, each of them with an xbee shield and and an xbee. I am running a dumb script on the arduino. I downloaded the XCTU and I am able to see both xbee in it and I can change the settings and so on and so forth, however, as I try to communicate between them I am unable. I am sure I am doing something basically wrong. The shields are from dfbot and there are 2 switches on that, one sets either USB or XBEE - I am selecting usb when I need to write the on the component and select xbee when I want to communicate between them an dth eother one is between run and program, I have this on run. The two xbee are in default mode, I tried to make changes to the DL, the DH and the DY but with no luck ... any suggestions ?

Thanks,
Giuseppe
asked Sep 1, 2017 in RF Solutions and XBee by giuseppeselli New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Try using API mode. Also try removing the XBee modules from the hardware and simply run a wire between Tx and Rx where the radios would otherwise be connected. That is the Tx of board 1 in the Rx of board 2.
answered Sep 1, 2017 by mvut Veteran of the Digi Community (11,302 points)
Hi, thanks for your suggestions. I guess I can try in API mode, however I do not understand the other suggestion. I know the shield works since I can detect the two xbee, I cannot comunicate between the two xbees, that is my issue
Most Arduino code requires the Xbee modules to be in API mode. That is why I mentioned that.

The other recommendation is to verify that you had the correct lines being used to send and receive data over the xbee. By removing the XBee and wiring it directly, you could eliminate API mode and just see if the devices worked cabled to each other.  IE verify that you are using the proper pins for DI and DO.
...