Home/Support/Support Forum/Xbee-S2C with CC2650 ZED- ZED could not initialize end device message

Xbee-S2C with CC2650 ZED- ZED could not initialize end device message

0 votes
Xbee- S2C Module - Using XCTU tool configured as a Coordinator along with CC2650 HA profile set as a ZED
Both the device connected to each other, Xbee announce the device registration and device association successful message

My Question is after that ZED ask data request to ZC(Xbee-S2C) but no further data exchange

ZED device requesting data to ZC continuously and keep on asking

Please guide further
1. What is the reason for not responding to data request?
2. IS ZC support HA profile?
3. I read user guide- XBee S2C support both switch and Thermostat cluster
4. ZED CC2650 supports HA profile and developed based on temperature cluster
5. In Console window - We can see both ZED and ZC, ZED device successfully connected to ZC then also no further data frame received at ZC
asked Apr 4, 2017 in IEEE 802.15.4 by santosh.india New to the Community (2 points)

Please log in or register to answer this question.

1 Answer

0 votes
The S2C only supports the HA profile to a point. That is, it will allow association but all other functions require you to use API mode with API explicit frames and you must write the application side to support thoughts functions. That is, if you want to poll or read a ZDO command, then you must write an application that uses the XBee modules API interface and is capable of sending and understanding the ZDO functions.
answered Apr 10, 2017 by mvut Veteran of the Digi Community (11,300 points)
...