Home/Support/Support Forum/XBee raising data received event in C# when writing data

XBee raising data received event in C# when writing data

0 votes
Hi, I'm working on a project with a sensor connected to an arduino which sends the data from an end device XBee S1 in API mode to a coordinator XBee and handles the data in Visual Studio using C#. The data gets send when a flag is raised. The coordinator can receive the data just fine but I'm having issues when writing data from the coordinator and broadcast it to the end device(I eventually want to have multiple end devices connected). I want to have the coordinator send a frame to the end devices every X seconds but when writing data, it is for some reason causing bytes to be received into the XBee coordinator which leads to the data received event to be called and it eventually reads a 0x7E byte and thinks it is an XBee frame and then causes an out of bounds error when I try to parse the incoming frame. Anyone know of any solution or possible causes on the data being received by the coordinator even though no data has been sent by the end device? Thanks.
asked Oct 23, 2016 in IEEE 802.15.4 by Alex-ULV New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Probably your Coordinator is pointing to itself under Destination addressing parameters (DH & DL).

In order to broadcast data from Coordinator to all End Devices, set DH=0x0 and DL=0xFFFF on Coordinator.

0xFFFF is broadcast address in XBee modules while 0x0 is alias address for Coordinator.
answered Oct 24, 2016 by asgm Veteran of the Digi Community (1,408 points)
...