Home/Support/Support Forum/Buffered IO Samples

Buffered IO Samples

0 votes
For a specific project I have configured an XBee API End Node with Pin Sleep and Change detection Sampling.

This the Pin sleep and digital change is managed by a MC.

Currently, I'm waiting 100ms between forcing the digital change and setting the module back to sleep.

90% of the times it works and the controller (plugged-in to a Raspberry Pi) receives the messages, but the other 10%, the end node (or the controller, I'm not sure...) seem to buffer the frames for a random period of time, just to fire them up all at once afterwards.

Am I not waiting long enough before setting the XBee to Sleep, not allowing the frame to be transmitted?

Or has anyone heard about any recent issues with the libftdi library + Raspberry pi + XBee. I've searched but I couldn't find any recent ones.

Thanks in advance for the help.
asked Sep 2, 2016 in Miscellaneous Hardware and Software by cvicente New to the Community (6 points)

Please log in or register to answer this question.

1 Answer

0 votes
Which XBee module and associated firmware are you working with?

Are the IO lines that are being samples on the XBee module or on your Raspberry Pi?
answered Sep 2, 2016 by mvut Veteran of the Digi Community (12,786 points)
Hi mvut,

Thank you for you answer.

The IO lines being sampled (in this case is just one) is from the XBee module.

The XBee End node is running the firmware version 29A7 and the Coordinator the 21A7.

The Raspberry pi is only being used to interpret the frames arriving at the XBee coordinator which is connected to it.
Are you sending the remote AT command IS to force a sample or are you using the Change Detect function (IC) on the end device radio?
...