Home/Support/Support Forum/Digimesh "Find Neighbor" Slow Response...

Digimesh "Find Neighbor" Slow Response...

0 votes
Setup:
-2 Xbee S1 2.4Ghz-DM
-Firmware: 8073

Settings Default, except for :
-API without Escape
-Baud: 115200
-'NO' to 4(Append RSSI to end of response)

One local Xbee is connected to /dev/ttyUSB0 via the Sparkfun Explorer.
I issue a 'FN' from Command window in XCTU(Linux) and it takes 3-5 seconds to get a response from remote Xbee plugged into another Sparkfun Explorer, plugged into a usb battery pack.

Is this the expected response time for a single remote node when the 'FN' command is issued?
3-5 seems like a long time... I really need milli-second(ms) timings.

Please help.. how do I make it respond faster, if possible. My application is to use Digimesh to do realtime tracking of moving assets based on RSSI. I am testing with 2.4-DM but plan to use 900-SX. Please let me know if this a stupid/not possible idea with this technology.

Thanks!
asked Aug 31, 2016 in DigiMesh Proprietary Mesh Networking by spacetime New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

+1 vote
I would expect it to be a little better but that also depends on your BH an NH commands. But I would not expect it to be in the ms time frame. Simply put, no mesh based product can provide that kind of data in the ms time frame. The mesh based protocols simply are not designed for that. Now the Point to point and Point to multi-point protocols, that's another story.
answered Aug 31, 2016 by mvut Veteran of the Digi Community (12,657 points)
thanks mvut!
Please tell me the "Point to Multi-Point story!
If I set the destination address of the remote to the local, am I in effect creating a p-to-m-p scenario in digimesh, or do I need to re-flash? If so with what? Thanks.
...