Home/Support/Support Forum/Linux, "dgrp: net receive: sent reset to node - improper window sequence" in ConnectPort TS8/16
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Linux, "dgrp: net receive: sent reset to node - improper window sequence" in ConnectPort TS8/16

0 votes
I get this message in /var/log/messages: "dgrp: net receive: Sent Reset to node D - Improper Window Sequence".

I'm using:
- ConnectPort TS16 and TS8
- Digi RealPort driver version: 1.9-36
- Firmware version: 2.18.0 (version 82001474_F 05/15/2015) and 2.19.0.2 (version 82001474_H 04/14/2016)
- Linux Kernel 2.6.28.10

Issues:
- With 2015 firmware version the message is more frequent, with 2016 firmware version the message is less frequent.
- I lose communication with my device attached to the RealPort and his Serial Parameters change:

$ stty < /dev/ttyD3
speed 9600 baud; line = 0;
intr = M-^?; quit = M-^?; min = 1; time = 0;
-icrnl ixoff ixany -imaxbel
-opost -onlcr
-icanon -iexten -echo -echoctl -echoke

$ stty < /dev/ttyD3
speed 9600 baud; line = 0;
min = 1; time = 0;
-brkint -icrnl ixany -imaxbel
-opost -onlcr
-isig -icanon -iexten -echo -echoctl -echoke


When I upgrade to the latest Firmware version (2.19.1, Version 82001474_J 07/28/2016) I see no more the message: "Sent Reset to node D...", but I still have the same problems, lose communication and change the tty parameters.


I use the same environment production with Port Server TS16 and TS8 devices and no problems, the issue only appears in New Connectport devices.

Thnks for your help!
asked Aug 30, 2016 in Realport by samx New to the Community (0 points)
I also see that drpd shutdown connection every 2 minutes and reconnects every 10 seconds. This is the log in /var/log/syslog:

$ grep drp /var/log/syslog
Aug 31 14:08:43 localhost drpd: drpd(D,10.10.10.252) Driver shutdown connection
Aug 31 14:08:53 localhost drpd: drpd(D,10.10.10.252) Connected to  Server
Aug 31 14:11:15 localhost drpd: drpd(D,10.10.10.252) Driver shutdown connection
Aug 31 14:11:25 localhost drpd: drpd(D,10.10.10.252) Connected to  Server
Aug 31 14:13:32 localhost drpd: drpd(D,10.10.10.252) Driver shutdown connection
Aug 31 14:13:42 localhost drpd: drpd(D,10.10.10.252) Connected to  Server
Aug 31 14:14:14 localhost drpd: drpd(D,10.10.10.252) Driver shutdown connection
Aug 31 14:14:24 localhost drpd: drpd(D,10.10.10.252) Connected to  Server

As I posted before, this behavior and messages aren't when I put PortServer devices in my environment production, misbehaviour only occurs with ConnectPort devices, even with the latest driver and firmware version:

        Model:          ConnectPort TS 8
     Firmware:     2.19.1   (Version 82001474_J 07/28/2016)
     POST:          1.1.3   (release_82001476_C)                
        
        Digi RealPort driver version: 1.9-36

Please log in or register to answer this question.

1 Answer

0 votes
Is the device on the local LAN? If not, please try implementing a WAN Link speed:

http://knowledge.digi.com/articles/Knowledge_Base_Article/What-does-the-RealPort-WAN-link-setting-do

http://knowledge.digi.com/articles/Knowledge_Base_Article/High-CPU-usage-is-observed-when-running-RealPort-over-WAN-connections-in-Linux
answered Sep 8, 2016 by userid0 Veteran of the Digi Community (2,158 points)
...