Home/Support/Support Forum/Does the node need a delay for other operations after ATND command?

Does the node need a delay for other operations after ATND command?

0 votes
Hi,

I'm using XBee Pro 538, say I have three nodes. I sent ATND command to one node in order to find another two nodes. Then I wait for probably 20 seconds and get info of other two. After that, I want to configure both of them by sending Remote AT command. However, it fails all the time, which means I cannot get response.

It seems I need a delay of more than 10 seconds, after sending ATND command and getting info of other two nodes, even three '/r' received.

Here is my steps:
a) send "+++" to enter AT command mode.
b) send "ATND" to do network discovery.
c) receive info from other two nodes.
d) receive the third '/r'.
e) send Remote AT command.

For step e), it fails without a large delay...

Could anyone tell me what the problem is? Or give some hints.


Thanks a lot.
asked Jul 7, 2016 in IEEE 802.15.4 by MianTang New to the Community (2 points)

Please log in or register to answer this question.

1 Answer

+1 vote
 
Best answer
Hello MianTang,

The radio from which you wish to send the remote AT commands must be in API mode.

When in API mode, the radio will see the properly formulated packet and treat it properly.

If you were to do this in AT mode, it would send the characters from Radio A to Radio B and Radio B would output those characters as regular serial data.
answered Jul 7, 2016 by Rocker1446 Seasoned Professional (227 points)
selected Jul 8, 2016 by MianTang
Hello Rocker1446,

I also tried the API mode, and it is the same thing. Say I have three nodes: A, B and C. All three nodes are in API mode. And I send ATND command to Node A to search another two nodes.
I can find Node B and C. But I don't know when ATND searching stops. I just wait for a long time and quit from my codes automatically. And then, I send remote AT command in order to configure Node B and C, and there is no response.
Is it the probelm that Noda A is still in network discovery process? If it is, how to stop network discovery after sending ATND command?

Thank you for your quick response.
I think you are right. After updating my codes and getting a bug fixed. It works well now in API mode.

Thanks a lot.
...