Home/Support/Support Forum/XCTU problem with S2C modules

XCTU problem with S2C modules

0 votes
Hi,

we currently have problems in reading the configuration from S2C modules with XCTU - by using the SparkFun XBee Explorer USB.

We have seen under the following link

http://www.digi.com/support/forum/52015/how-to-add-a-s2c-programmable-module-to-xctu-6-3

that S2C modules have to be prepared by programming with boot loader to receive/see configuration within XCTU. Is that really necessary?

We have bought brand new modules like always and we never had to program such modules before.

Normally XCTU instantly detects the modules after pluging.

Any ideas?
Br,
Oliver
asked Jun 22, 2016 in RF Solutions and XBee by oheuser New to the Community (1 point)

Please log in or register to answer this question.

6 Answers

0 votes
What is the full part number of the S2C modules you have?
answered Jun 23, 2016 by mvut Veteran of the Digi Community (11,204 points)
0 votes
Hi,

the full part number is XBP24CZ7WITB003.

Currently we investigated that the modules were detected, but only if a 2nd try was started to connect the modules. For us it seems that the communication is only established indirectly and for some specific reason not with the first try. Independently of the back plane which is used to place the modules to connect to the host. We tried either the SparkFun XBee Explorer and the XBee Grove Dev. Board.

X-CTU version is 6.1.3

Br
answered Jun 24, 2016 by oheuser New to the Community (1 point)
0 votes
Hi ,
Even i encountered the same problem, did you resolve it?
if yes can you please guide me through the process.

Thank you
answered Nov 29, 2016 by dhruva New to the Community (1 point)
0 votes
For us the solution was to load the correct firmware on the module, by browsing through firmware explorer.
The firmware working for that module is:
Product family => XB24C
Function Set => ZIGBEE TH Reg
Firmware version => 4059

This firmware can be loaded by going to update firmware after the connection is made or by going through advanced options at the start even when XCTU couldn't detect it automatically.

Make sure to check the option "Force the module to maintain its current configuration" in the firmware selection window.
answered Nov 30, 2016 by shimesami New to the Community (2 points)
edited Nov 30, 2016 by shimesami
It did not work, what do I do?
0 votes
I have a problem just like yours. I have same model of xbee and my xctu is 6.3. Please tell me step by step how you solved it, I could not understand what you did to solve.
answered Nov 15, 2017 by evandrojr18 New to the Community (1 point)
What I would do is open a terminal window on the same COM port but enable the break and assert RTS. Then hit the rest button on the interface board. deselect the break and issue a <CR>.  A menu will come up. Pressing B will put you in bypass mode.  Once in bypass mode, use the same steps as before to write the new firmware to the module.
0 votes
I had problems with some s2c modules too (some worked just fine). In my case it turned out that those that didn't load in XCTU needed legacy-firmware support (Firmware version 4059). After downloading and installing the legacy firmware, the modules where detected properly and I was able to upgrade and configure the modules.
answered Aug 8 by Erwin van Dijk New to the Community (1 point)
Contact a Digi expert and get started today! Contact Us
...