Home/Support/Support Forum/API Node Discovery only Co-Ordinator responding

API Node Discovery only Co-Ordinator responding

0 votes
Hi,

I have two Xbee Pro Series 2 devices in API mode, one set as Co-Ordinator (firmware 21A7, with NI set to 'MASTER') and one set as an end device (firmware 29A7, with NI set to 'SLAVE'). I'm using XCTU for OSX, version 6.3.1, which is still buggy... :-(

The co-ordinator is physically attached to the USB port of an iMac, and the end device is attached to an Arduino.

If I switch to the console and issue an ND command (7E 00 04 08 02 4E 44 63), only the co-ordinator replies, even though if I switch to Network mode and issue a 'scan', XCTU finds the slave device, which I assume is using the node discovery command? If not, what is it doing differently, that it discovers devices across the wireless link?

The replies from the co-ordinator come twice, first as an 88 response with an error (status 01 'status error'), then a valid 88 response, with the relevant info, including the ASCII for 'MASTER', as you would expect. The end device never responds.

I had an old sketch running in Processing, which issued exactly the same packet, and which used to gather the names of both devices, and now this no longer works, even when XCTU is not running, so it appears not to be an XCTU bug.

I can send TX requests with a data payload with no problems from the Arduino, as well as other commands, and as I say, the network scan in XCTU works fine, so it's not as if the devices don't know each other is there, just that ND is stubbornly refusing to work, despite me trying every setting under the Sun! In any event, I hadn't changed any settings until trying to figure this out.

I've scoured the forums, here and elsewhere, and can find no answer to this issue.

Help would be appreciated.


Regards,

G
asked May 5, 2016 in RF Solutions and XBee by GiulioZ New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Try doing an ND to the NI value of the End device. Also increase your Node Discovery timeout to be greater than your Sleep cycle is on your end device.
answered May 9, 2016 by mvut Veteran of the Digi Community (11,963 points)
...