Home/Support/Support Forum/Can not program older XBee radio via CoolTerm or XCTU

Can not program older XBee radio via CoolTerm or XCTU

0 votes
I am trying to program an older XBee radio via the Sparkfun XBee Explorer USB. However, it is an older radio and still says "MaxStream". I have the FTDI drivers installed, and can see the radio in the device manager (shows up on COM3). But when I run either CoolTerm or XCTU and use COM3 (the only port it finds), I get no feedback from the radio at all. CoolTerm never echos anything back from the radio, and XCTU says no radio found on that port. Is this because I have an older radio? Or am I doing something wrong?
asked Apr 28, 2016 in XBee Programmable Development by 3DPiper New to the Community (2 points)

Please log in or register to answer this question.

1 Answer

0 votes
What is the full part number of the XBee module you are working with? It should be on the white label and read something like XBP24-AWI-001?


What version of XCTU are you working with?

Does the 3rd party Explorer board have the DTR and RTS lines connected thru?
answered Apr 28, 2016 by mvut Veteran of the Digi Community (11,966 points)
The part number is XBP24-AWI-001 revC 2009-11-24

I am working with the latest version of XCTU (just downloaded yesterday, 6.3.1)

The xbee explorer board has TX and RX LEDs that do blink when I type into CoolTerm, so I do think it is getting info
XCTU 6x wants DTR and RTS connected between the XBee and the PC in order to read or write firmware to the module.  The module is most likely at a different baud rate than the default.  You can force the radio at the default baud rate by using the Terminal function in XCTU's Tools menu. Then configure the port for 9600 baud. Then enable the Break function, disable DTR and hit the reset on the radio. You should then get an OK. Release the break and issue an ATRE, WR, CN
Ahh, thank you. With the Tools/Serial Console (I guess that is terminal?) I was able to get some interactivity when clicking 'BREAK'. I then went back to 'Discover Radio Modules' and just hit 'select all'. It took awhile, but finally found the radio! It was set to 1200 baud. Thank you!
...