Home/Support/Support Forum/TI TM4C129 Launchpad and XBee

TI TM4C129 Launchpad and XBee

0 votes
I am using TM4C129 Launchpad launchpad and trying to connect XBee Series 2 (S2C) through UART.

Looking into the pinout of TM4C129 (http://energia.nu/wordpress/wp-content/uploads/2014/06/LaunchPads-LM4F-TM4C-%E2%80%94-Pins-Maps-13-34.jpeg), I am connecting like below

XBee TX <---> RX

XBee RX <---> TX

XBee 3.3V <---> pin#41

XBee GND <---> pin#62

use below code on the LaunchPad at Energia

void setup()
//pinMode(13, OUTPUT);

void loop()


And the below python code runs on my Mac as a coordinator


import serial

ser = serial.Serial('/dev/tty.usbserial-A104IC2U', 9600)

while True:
incoming = ser.readline().strip()
print '%s' % incoming

But it doesn't work. FYI, this code worked on Arduino.

Has anyone tried this before? Any suggestion?
asked Apr 22, 2016 in RF Solutions and XBee by lilyhack New to the Community (4 points)

Please log in or register to answer this question.

1 Answer

0 votes
I think UART0 is software serial so instead I used UART3 for connecting the XBee and in the code used Serial3.

That resolved it.
answered Apr 23, 2016 by lilyhack New to the Community (4 points)