Home/Support/Support Forum/Problem with S2C and XStick

Problem with S2C and XStick

0 votes
Hi all,
i have a problem in comunication between XStick and a new S2C (Zigbee TH Reg).

They are in the same PANID, they can discover eachother but when i try to console a string (in ASCII) from XSTICK i get this (using sscom32E or other programs):

XSTICK i write: "hello" -> S2C i read "“~¢@÷ƒ\´©hello"

Can you tell me why?

XStick: XB24-ZB - Zigbee Coordinator API
S2C: XB24C - ZIGBEE TH REG

Many Thanks!
asked Mar 16, 2016 in XBee Programmable Development by jergo New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
 
Best answer
That is because your Coordinator or XStick is in API mode which uses Hex characters to send and receive data.
answered Mar 17, 2016 by mvut Veteran of the Digi Community (11,300 points)
selected Mar 17, 2016 by jergo
Hi, thanks for the reply.

In coordinator AT mode i can't see the S2C in the network, how can i change to ASCII from HEX?

Is for this reason too that from XStick i can't send messages to S2C?
Yes that is why you can't send ASCII data on your XStick. Your XStick is configured for Hex API packets within the firmware it is running.  You would need to change the firmware on the XStick to Coordinator AT to change it from Hex API frames to transparent ASCII data.
Many thanks for your patience.
Yes, when i set as Coordinator AT and i connect to a XBee X2 i have no problema, but when i try to connect the XStick to a S2C version, i can't discover it.
The S2C is incompatible? Or do i need to have a specific set-up?

Thanks!
Try setting the S2C to match the SC value of the XStick and make sure that the CE function on the S2C is disabled.
...