Home/Support/Support Forum/How to avoid error Update Firmware on XBee s2 via X CTU

How to avoid error Update Firmware on XBee s2 via X CTU

0 votes
I have 2 Xbee S2 Modules (ZigBee Router AT) (https://www.sparkfun.com/products/10414) that are set as "Router AT" with firmware verison 228C.

I have 2 Explorer Boards (USB) and i am using the XCTU software to help me update the radio module firmware. However when i select "coordinator AT" it will give me 7 firmware versions: 20A7 (Newest), 20A0, 208C, 2070, 2064,2041,2021. Which one do i choose?

My explorer board is from Adafruit. https://www.adafruit.com/images/1200x900/247-01.jpg

Once i update the radio module via XCTU 4/5 are [OK] but the last check says [ERROR].
"
- Getting device information... [OK]
- Entering programming mode... [OK]
- Configuring port for bootloader... [OK]
- Getting hardware version... [OK]
Hardware version: 0x19
- Transferring Radio firmware... [ERROR]
Could not program the radio module. > Error decrypting the firmware file > C:\Program Files (x86)\Digi\XCTU-NG\radio_firmwares\xbee_zb\XB24-ZB_20A7.ehx2.dec (Access is denied)"
asked Feb 23, 2016 in XCTU by chuetouyang New to the Community (0 points)
edited Feb 23, 2016 by chuetouyang

Please log in or register to answer this question.

1 Answer

0 votes
The correct firmware versions would be 20A7. But you need a board that has DTR and RTS connected thru in order to change firmware. I would suggest checking with Spark Fun to see if your version of their board has these lines connected thru.
answered Feb 23, 2016 by mvut Veteran of the Digi Community (11,298 points)
The one i purchased from adafruit has "DTRn" and RTSn" would that make any difference?
For writing the firmware yes.  For encrypting the file no. What you are going to need to do is to delete the file XB24-ZB20A7.ebl from the C:\program files x86\Digi\XCTU\update\ebl folder and the XBeeS2 folder from the update folder. Then download the firmware files again.
...