Home/Support/Support Forum/Forcing UART operation wirelessly

Forcing UART operation wirelessly

0 votes
Hi,

I'm using XBee with an UART device powered by ON/SLEEP pin.

The problem is that whenever I connect my XBee to the device it forces SPI connection and according to the manual that is because I'm asserting DOUT low during reset, but maybe that is because the device is waiting for power up.

When forcing SPI the pins D1,D2,D3,D4 and P2 get changed to SPI parameters and I cannot revert to Disable because of Status Error (wirelessly)

Is possible to force UART operation wirelessly after SPI operation was forced?

I'm Using XBee 900HP with firmware 8071.
asked Feb 15, 2016 in DigiMesh Proprietary Mesh Networking by progloverfan New to the Community (17 points)

Please log in or register to answer this question.

1 Answer

+1 vote
 
Best answer
DOUT is suppose to be controlled by the radio and not your device. If your device is holding it low, then that is an issue. It should be floating.
answered Feb 17, 2016 by mvut Veteran of the Digi Community (14,249 points)
selected Feb 18, 2016 by progloverfan
I'll check that because DOUT is connected to the RX of the device so there shouldn't be problems.
Make sure that you have not disabled the internal pull up on the Dout line (PR bit 14).  If you are continent that this line is high, you can always issue a remote AT commands via the API interface that does a reset (ATFR). This will tell the module to reset and should if the Dout line is not held low, disable the SPI port.
I've cut the DOUT line and now XBee works as UART serial mode, it was an electrical thing, and really don't know the exact cause.
...