Home/Support/Support Forum/WR44 SSH Fails
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

WR44 SSH Fails

0 votes
I have a WR44, reset to factory defaults, with the firewall off. This has a cellular pp1 connection with the SSH server enabled. When I attempt to SSH using PuTTY, I receive a "Server unexpectedly closed network connection" message.
asked Feb 8, 2016 in Digi TransPort Cellular by JeffSorn New to the Community (0 points)

Please log in or register to answer this question.

2 Answers

0 votes
Hi

are you actualy getting to the router?
is it a public address on PPP 1 ?
can you access the touter via telnetn / http?
does SSH work on eth interface ?
is there any errors in eventlog.txt ?

has the cert been built on the router ?
is it refrenced in SSH ?

regards

James
answered Feb 9, 2016 by James.Wilson Veteran of the Digi Community (1,225 points)
Thank you for a nudge in the right direction James! It turns out that SSH referenced a non-existent priSSH.pem cert. I pointed SSH to the privrsa.pem cert and I can now SSH to the box.

Thanks again,
Jeff
0 votes
It works with putty so this is strange.
It doesn't work with open ssh v2 on linux. You'll need to force open ssh to use sshV1 to make it go but putty works on both.

it may be that the firewall is on?
answered Jul 6, 2016 by jserink Community Contributor (52 points)
Hi

from what i can see the transport does not have an issue with DH groups and does not support the once used by openssh in v2 mode

regards

James
...