Home/Support/Support Forum/DIO6 pin configured for digital out low/high

DIO6 pin configured for digital out low/high

0 votes
DIO7 configured as digital high or low is no problem. DIO6 however, when configured as a digital output high or low is always acting like an open circuit when probed on the oscilloscope. Does someone know what's going on here? Can someone at least confirm that when they set DIO6 as a digital high that that is what they get? Everything is at default value apart from this setting (AT coordinator or router). The model is a xbp24z7.
asked Feb 3, 2016 in RF Solutions and XBee by Famo New to the Community (1 point)

Please log in or register to answer this question.

2 Answers

0 votes
What is the full part number of the module in question and what firmware version are you working with?
answered Feb 3, 2016 by mvut Veteran of the Digi Community (12,315 points)
0 votes
Thanks for replying.

Its an xbp24bz7sitb003j rev f. The firmware is 22A7 (AT router)
answered Feb 3, 2016 by Famo New to the Community (1 point)
That is a Programmable module. You need to write Code and upload it to the Freescale processor in order to control that line. Otherwise it is in a tri state.
OK. Are you saying that this is the case for DIO6 but not DIO7? With DIO7 I can set it as a digital output high within the settings in X-CTU and that is what I get but this is not the case with DIO6.
Yes, some of the lines are controlled by both processor and some are not. You really need to look at the product manual and the Pin map in Code Warrior to determine which lines are controlled by which processor and when.
Thanks for the advice. It's been years since I've read the product manual so I'll dig through it again.
...