Home/Support/Support Forum/discovering mode error ,immediate help me ...

discovering mode error ,immediate help me ...

+1 vote
I am using an Arduino wireless shield. I had no problems before the change to API and the other Xbee s2 I have which is still in AT mode is recognized.

I get the following error:

could not find any device in COM 8>error initializing xbee device parameters>connection timeout >Could not read Hardware and Firmware version.
thanks for everthıng
asked Dec 20, 2015 in RF Solutions and XBee by ferhat New to the Community (7 points)
edited Dec 20, 2015 by ferhat

Please log in or register to answer this question.

5 Answers

0 votes
What software is reporting this message?
answered Dec 21, 2015 by mvut Veteran of the Digi Community (13,104 points)
0 votes
I used to x-ctu
answered Dec 21, 2015 by ferhat New to the Community (7 points)
0 votes
i have same problem.you can use x ctu legacy version for API mode
answered Dec 22, 2015 by mahesh7393 Seasoned Professional (190 points)
Yes you can.
yes ,change at mode to apı mode
0 votes
What do you have the XBee module mounted on? If it is not one of Digi's interface boards, then you may be having issues with the board you are using not providing a connection from the PC to the module on all of the required lines such as DTR and RTS.
answered Dec 22, 2015 by mvut Veteran of the Digi Community (13,104 points)
The bulk of the Shields do not provide the necessary lines needed to change firmware. You need to contact the vendor of the shield for help in connecting the DTR and RTS lines if you want to change firmware using that board.
I take issue XBee explorer dongle reversible to buy ?
You need to check with the manufacture of the board first to verify that the DTR and RTS lines are connected on it before you purchase it.
My English is not very good, ı don't understand dtr ,rts ???
These are the hardware flow control lines used in an RS232 or 3V CMOS connection.   They are required lines for updating firmware on the XBee modules.  Most Arduino or Shield boards don't add them. They only connect the minimum lines needed for two way communications.
0 votes
solution : If with XBee explorer dongle firmware update it is done running smoothly.

arduino xbee shield does not allow firmware update.
answered Feb 15, 2016 by ferhat New to the Community (7 points)
...