Home/Support/Support Forum/Yes, Digi modules. Old uboot image looks like running a bit; new not.
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Yes, Digi modules. Old uboot image looks like running a bit; new not.

0 votes
Thank you so much for answer ( i am a bit lost ...)

The board i use to program is : Digi CCWi-i.MX28 number 5001837-01 (ref on back 30013792-03 Rev A)

I made different tests with differents CCWMX28, for instance
* 50001838-24-revB
* or 50001838-05-revC
* and other

I first re-programm uBoot using "sb_loader" and the u-boot provided on Digi DVD.
* With the file "u-boot-ccardwmx28js-ivt.sb" U-Boot 2009.08 - DUB-1.3.0.3 - (Jun 06 2012 - 10:16:33) - GCC 4.4.6
Just after the USB transfer, i leave the boot up to linux and i can access normally the eth0 & 1
After the reboot, not. (like if it has not been stored)

* With U-Boot 2009.08 - DUB-1.5.1.3 - (Feb 19 2013 - 11:37:37) - GCC 4.4.6 or ConnectCard Wi-i.MX28
No Eth; neither before or after reboot.


And, with all the uBoot i tried to make : nothing with eth (or WiFi)

I tried to re-configure a fully new installed PC with only Digi DVD Kubuntu from scratch; with old version, new versions : nothing

But, i have a tens of old card(RevA) fully running. I did the job some monthes (or years ...) ago with no problem.

So, your help is really wellcomed

Thanks

Xavier DAVID BEAULIEU
asked May 18, 2015 in Linux by xavierdb New to the Community (3 points)

Please log in or register to answer this question.

3 Answers

0 votes
Make sure you are programing it into flash, use the update command. Take a look at uboot manual.
http://ftp1.digi.com/support/documentation/90001129_B.pdf

Section 10.3 shows how to perform an update
answered May 20, 2015 by Campbell Veteran of the Digi Community (742 points)
0 votes
It looks like you have a ccwimx28 V3 module, but you are building your own u-boot using DEL that is not up to date and does not fully support V3 variant. What version of DEL are you using? Did you install all the patches via package manager? what is Part number and serial number of the module you are using? Do you need to customize a u-boot?
answered May 26, 2015 by LeonidM Veteran of the Digi Community (3,731 points)
OK for uboot with new DEL updates but not WiFi
0 votes
You should probably open a support case for this if the issue is not resolved by installing the latest patches to DEL and then creating a new U-boot project.
answered May 26, 2015 by LeonidM Veteran of the Digi Community (3,731 points)
...