Home/Support/Support Forum/not able to receive response from xbee s2b coordinator for VR command through dotnet software

not able to receive response from xbee s2b coordinator for VR command through dotnet software

0 votes
I have configured a XBEE-PRO-S2B module as a coordinator. When I send VR command from xctu software to this coordinator it instantly gives response to it as shown:

AT Command - VR - firmware version

7E 00 04 08 01 56 52 4E
- Start delimiter: 7E
- Length: 00 04 (4)
- Frame type: 08 (AT Command)
- Frame ID: 01 (1)
- AT Command: 56 52 (VR)
- Checksum: 4E

AT Command Response

7E 00 07 88 01 56 52 00 21 A7 06

- Start delimiter: 7E
- Length: 00 07 (7)
- Frame type: 88 (AT Command Response)
- Frame ID: 01 (1)
- AT Command: 56 52 (VR)
- Status: 00 (Status OK)
- Response: 21 A7
- Checksum: 06

Now my problem is when I send the command in same format to coordinator through my DOTNET software program on USB port as serial communication, I am not receiving the response though the coordinator is receiving the query.
I discovered the reason that though I am sending the frame in HEX format it is getting converted into ASCII at the coordinator's side which shows it is receiving query in wrong format. Same I checked with XCTU there it is not getting converted into ASCII at coordinator's side instead it is receiving the query into HEX format which is in right format.
Why my coordinator is not receiving correct format through DOTNET software program?
Kindly provide me any solution over this. Thank You
asked Apr 27, 2015 in IEEE 802.11 (Wi-Fi) by poonam patil New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
From the sounds of it, you need to learn how to tell the .net framework ho to issue data in Intel Hex instead of the default ASCII. Try searching social.technet.microsoft.com for Hex data with .net.
answered Apr 27, 2015 by mvut Veteran of the Digi Community (11,298 points)
...