Home/Support/Support Forum/AT command response to DB

AT command response to DB

0 votes
I am looking to keep track of the RSSI values on every received packet. However, when I send the 'D''B' command to the module only about a third of the responses have a valid range, the other 2/3's will respond with an "OK"/0x00 command status, but the command data is 0x00.

The module is awake the entire time between transmitting, receiving, and querying the RSSI register and the AT command is sent after 0x8B "success" transmit response.

Are there any other settings / commands / steps that I can take to ensure that I receive a valid response range every time?
asked Apr 16, 2015 in RF Solutions and XBee by ndauzat New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Which product and firmware version are you working with?
answered Apr 16, 2015 by mvut Veteran of the Digi Community (12,779 points)
This is occurring on a XBee S2C with firmware version 401E
May I suggest you start by updating your firmware version to the most current version available?  there is a very real possibility of it already being addressed.
...