Home/Support/Support Forum/Switched messages during streaming data between Xbee S2 and Xstick XU-Z11

Switched messages during streaming data between Xbee S2 and Xstick XU-Z11

0 votes
Hi,

We are using several xbee series 2 in API mode and several Xstick Xbee USB Adapter XU-Z11, to create different networks for stream data purposes . Mainly we are using 2 xbee series 2 module per USB Xstick. For instance, we are streaming data from those 2 xbees modules at the rate of 128 payload bytes (each module) every 150milliseconds (approx 6.67Hz). We already disable the ACKs from xbees, and add a counter with the index of each sending message, and some times we experience some switches between messages, in other words, we receive first the actual send message and then the previous one. For example, message index, 1,2,3,4,5, 7 , 6 ,8,9,10, receiving first the message number 7 instead 6.

For debug this issue we simplify the system and only test streaming data with only 1 xbee s2 module and a USB Xstick. And sometimes (rarely, but occurs) the switched messages. Also we had tested, instead use the USB Xstick, we use another xbee module s2 as a coordinator, and instead use a computer to receive the data we use a uC ARM based. And the result is the same, in occurs time to time.

Do you have any idea how this is possible to happen. Could be the fact of be a mesh network that somehow the messages are routed.

Additional info:
Routers xbees s2 modules baudrate: 34800
Coordinators USB Xsticks baudrate: 115200
asked Feb 16, 2015 in DigiMesh Proprietary Mesh Networking by aaraujo New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
The actual maximum payload for one RF packet is 84 bytes. Since you are actually transmitting two packets (Fragmentation) at the same time, it is very possible that they get received in different order than what was transmitted.
answered Feb 25, 2015 by mvut Veteran of the Digi Community (11,298 points)
...