Home/Support/Support Forum/"Permission denied/Line in use" error on TS16/linux
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

"Permission denied/Line in use" error on TS16/linux

0 votes
Hello all Digi-friends!
,

After installing the new Digi device driver- version grp-1.9-34.x86_64 - on SLES12 (Kernel 3.12.28-4-default) and succesfully started with:
systemctl start dgrp_daemon.service

- > I can not use any configured serial device:

cu -l /dev/tty_dgrp_ga_14
cu: creat (/var/lock/TMP000000605c): Permission denied
cu: /dev/tty_dgrp_ga_14: Line in use

Permissions:
dir /dev/tty_dgrp_ga_*
crw-rw-rw- 1 root root 246, 0 Jan 19 11:51 /dev/tty_dgrp_ga_0
crw-rw-rw- 1 root root 246, 1 Jan 19 11:51 /dev/tty_dgrp_ga_1
crw-rw-rw- 1 root root 246, 10 Jan 19 11:51 /dev/tty_dgrp_ga_10
crw-rw-rw- 1 root root 246, 11 Jan 19 11:51 /dev/tty_dgrp_ga_11
crw-rw-rw- 1 root root 246, 12 Jan 19 11:51 /dev/tty_dgrp_ga_12
crw-rw-rw- 1 root root 246, 13 Jan 19 11:51 /dev/tty_dgrp_ga_13
crw-rw-rw- 1 root root 246, 14 Jan 19 11:51 /dev/tty_dgrp_ga_14
...
dir /var/ | grep lock
drwxrwxr-x 5 root lock 100 Jan 19 00:00 lock


Pls help!


Best regards

Nikita Michalko
asked Jan 19, 2015 in Portserver TS by niki1444 New to the Community (3 points)

Please log in or register to answer this question.

1 Answer

0 votes
You should see devices called ttyga## in /dev rather than using the tty_dgrp_ga_## devices.

Make sure you have permissions for /var/lock. Also, you will need to change the port ownership:

chown uucp:uucp /dev/ttyga*

Make sure nothing is currently running on the ports:

fuser /dev/ttyga##
answered Jan 27, 2015 by userid0 Veteran of the Digi Community (2,156 points)
...