Home/Support/Support Forum/RCM6650W WiFi Modbus
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

RCM6650W WiFi Modbus

0 votes
I am using a RCM6650W module and would like to poll modbus data via the WiFi. I am using Ad-Hoc mode and I can get the interface up and running with the ability to ping the WiFi.

However, when I try to attach a modbus master, it fails over WiFi. I have this same project working on a RCM6760 and can poll modbus data over the physical ethernet with no problem.

I have read where certain processes can only use the Primary Default IP, is Modbus TCP one of those items or should it work over WiFi as well?

How can I disable ETH0 and make the WiFi0 the default?

Any suggestions would be appreciated.
asked Dec 19, 2014 in Rabbit by mcpritt New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
You can disable ethernet by putting the following in Project Options:

DISABLE_ETHERNET
answered Dec 21, 2014 by trooper2 Veteran of the Digi Community (589 points)
Thanks for the answer. Although this does help, I ended up having to set TCPCONFIG =0 and then manually configure the WiFi adapter settings. Modbus TCP worked fine over WiFi once I eliminated the other Ethernet port.
...