Home/Support/Support Forum/How can i read sensor data?

How can i read sensor data?

0 votes
Hi,

I have s1 2 xbeep24 and have atmega fio v3.I want too send(coordinator) my sensors data and read from xctu's serial(end device).I can see some strange characters not in ASCII.My end device's DL 1 MY 2 and DL 2 MY 1 in my coordinator(AES encryption key always red in both device).I tried other serial softwares but it didn't solution for me.I didn't use code about xbee.Just using serial.begin.


Im not english, if im spoke badly so sorry for it.
Kind Regards,
Eren
asked Dec 18, 2014 in IEEE 802.15.4 by Eren New to the Community (0 points)
edited Dec 18, 2014 by Eren

Please log in or register to answer this question.

2 Answers

0 votes
What kind of sensor do you have? Is it an Analog Sensor that is connected to one of the radios Enabled ADC lines or is it a UART enabled sensor?
answered Dec 23, 2014 by mvut Veteran of the Digi Community (11,300 points)
Thanks for the reply.I m using DHT 22 sensors for now.I set DIO0 ADC on receiver or transmitter or both of them.I tried anything about that.Im using simple code on arduino IDE for test.Here it is:

char letter;





void setup(){
  Serial.begin(9600);
}

void loop(){
  Serial.write('a');
  delay(400);
  if(Serial.available())
  {
    letter=Serial.read();
    Serial.print(letter);
  }}

I just want see data on my receivers serial monitor.I tried other serial programs but it didnt solve for me.

So i can communicate with the other xbee.When im open xctu s serial port and press any button on keyboard green led is lighting(on fiov3)

Where am i wrong?Thanks for the help again.
Have you looked at the documentation Adafruit has for how to connect these sensors to a device? You don't use the Analog input. You use the Data In line instead.   Try looking over https://learn.adafruit.com/dht/connecting-to-a-dhtxx-sensor. It should help you with your endeavor.
Thanks for the reply.The link is dead i guess.Anyway i set DIO 0 DI both devices.This make no sense.Why i cant see anything?Now my receiver settings: Ch:10 Pan ID:1132 dest. add.high:1   16 bit source adress 2     DIO 0: DO Low   Pull Up resistor: 1  input adress:1  

And my transmitter settings: Ch:10 pan id: 1132 dest.add.high :2      16 bit source add:1    DIO0= DI   Pull up resistor=0 samples before tx=5    sample rate:20


Thanks for the help again. I need really help about this. Where am i wrong ?
0 votes
You have the two back words. The DIO 0 line set as an input would be the Input or transmitting module. The other is the receiver of the DIO status change.
answered Jan 5, 2015 by mvut Veteran of the Digi Community (11,300 points)
Many thanks for the reply.I had a mistake in my last reply. I edited it.(Receiver settings:
ch:10  pan ıd:1132 dest.add. high:1 16 bit source:2 Dıo 0:DO low pull up res:1 input address:1
Transmitter settings:
ch:10 pan id:1132 dest.add.low:2  16 bit source add.:1 Dıo 0:DI(3)  pull up res:0 samples before tx:5  sample rate:20 input adress:FFFFFFFFFFFFFFFF)
Sorry for my mistake,thanks again.
I solve my problem.I set transmitter DIO 0 DI  receiver DIO 0 DO LOW.
And i write my code my fio s rx tx pins((0, 1)on fio. Lot of thanks for replies and helps.
Have good day,
Kind regards.
...